summaryrefslogtreecommitdiff
path: root/absl/numeric
diff options
context:
space:
mode:
authorGravatar Adrien Devresse <adrien.devresse@epfl.ch>2017-09-26 20:37:27 -0700
committerGravatar Adrien Devresse <adrien.devresse@epfl.ch>2017-10-27 18:46:36 +0200
commitd5134a7f11e32d11caa67e75ae2ae2e506fb54ba (patch)
treea79eb61722804e184840d5b29f6d5de83657fb2a /absl/numeric
parent962e9931d546cd6f062894e15283cea02c7d3220 (diff)
CMake support
- initial cmake support - downgrade cmake requirement to 2.8.12 - factorize cmake test flags / libs options - refactor test / library under helpers functions, follow bazel's style - Add fix for MSVC and Windows support ( thx @patrikfors ) - Switch to default "add_subdirectory()" usage mode - add CMake/README.md for instructions - add header-only cmake target generator - map absl target to absl:: namespace
Diffstat (limited to 'absl/numeric')
-rw-r--r--absl/numeric/CMakeLists.txt62
1 files changed, 62 insertions, 0 deletions
diff --git a/absl/numeric/CMakeLists.txt b/absl/numeric/CMakeLists.txt
new file mode 100644
index 00000000..3360b2ee
--- /dev/null
+++ b/absl/numeric/CMakeLists.txt
@@ -0,0 +1,62 @@
+#
+# Copyright 2017 The Abseil Authors.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+list(APPEND NUMERIC_PUBLIC_HEADERS
+ "int128.h"
+)
+
+
+# library 128
+list(APPEND INT128_SRC
+ "int128.cc"
+ ${NUMERIC_PUBLIC_HEADERS}
+)
+absl_library(
+ TARGET
+ absl_int128
+ SOURCES
+ ${INT128_SRC}
+ PUBLIC_LIBRARIES
+ ${INT128_PUBLIC_LIBRARIES}
+ EXPORT_NAME
+ int128
+)
+
+
+absl_header_library(
+ TARGET
+ absl_numeric
+ PUBLIC_LIBRARIES
+ absl::int128
+ EXPORT_NAME
+ numeric
+)
+
+# test int128_test
+set(INT128_TEST_SRC "int128_test.cc")
+set(INT128_TEST_PUBLIC_LIBRARIES absl::numeric absl::base)
+
+absl_test(
+ TARGET
+ int128_test
+ SOURCES
+ ${INT128_TEST_SRC}
+ PUBLIC_LIBRARIES
+ ${INT128_TEST_PUBLIC_LIBRARIES}
+)
+
+
+