summaryrefslogtreecommitdiff
path: root/absl/meta/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Evan Brown <ezb@google.com>2022-09-20 13:12:25 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2022-09-20 13:13:13 -0700
commitd859fafe1ab9edc9c04ca262d9993be82c757881 (patch)
tree6794fb010d0f423ea6a8fb65176efb9231ad095d /absl/meta/CMakeLists.txt
parent800c04f64afa48271c6eaee67da489a7ebf92757 (diff)
Change the macro ABSL_IS_TRIVIALLY_RELOCATABLE into a type trait - absl::is_trivially_relocatable - and move it from optimization.h to type_traits.h.
Example of how to change to the new type trait: ``` #include "absl/base/attributes.h" if (ABSL_IS_TRIVIALLY_RELOCATABLE(T)) { DoSomething(); } ``` to ``` #include "absl/meta/type_traits.h" if (absl::is_trivially_relocatable<T>::value) { DoSomething(); } ``` Note that optimization.h is also built in C mode so we can't put a type trait there. PiperOrigin-RevId: 475633715 Change-Id: I2bc85f3f6711d1280049fd01eb97c497d2d0d929
Diffstat (limited to 'absl/meta/CMakeLists.txt')
-rw-r--r--absl/meta/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/absl/meta/CMakeLists.txt b/absl/meta/CMakeLists.txt
index 9de4bd37..f16f17bd 100644
--- a/absl/meta/CMakeLists.txt
+++ b/absl/meta/CMakeLists.txt
@@ -34,6 +34,7 @@ absl_cc_test(
COPTS
${ABSL_TEST_COPTS}
DEPS
+ absl::core_headers
absl::type_traits
GTest::gmock_main
)