summaryrefslogtreecommitdiff
path: root/absl/log
diff options
context:
space:
mode:
authorGravatar Andy Getzendanner <durandal@google.com>2022-12-17 12:00:38 -0800
committerGravatar Copybara-Service <copybara-worker@google.com>2022-12-17 12:01:23 -0800
commit2468b189eec992ff810f88d7dfbdc5c4dd9094ea (patch)
tree065bbab0fa8ea076449c4d8ba3e8ff38da04d075 /absl/log
parent71927b43256b9252bfafffc951bcc8106156a811 (diff)
Use ABSL_LOG instead of LOG in absl::LogStreamer.
PiperOrigin-RevId: 496112752 Change-Id: I0a7a8854a642f63ddd3ba67b9268bbb0803118e9
Diffstat (limited to 'absl/log')
-rw-r--r--absl/log/BUILD.bazel2
-rw-r--r--absl/log/CMakeLists.txt2
-rw-r--r--absl/log/log_streamer.h6
3 files changed, 5 insertions, 5 deletions
diff --git a/absl/log/BUILD.bazel b/absl/log/BUILD.bazel
index 10916446..91639e64 100644
--- a/absl/log/BUILD.bazel
+++ b/absl/log/BUILD.bazel
@@ -186,7 +186,7 @@ cc_library(
copts = ABSL_DEFAULT_COPTS,
linkopts = ABSL_DEFAULT_LINKOPTS,
deps = [
- ":log",
+ ":absl_log",
"//absl/base:config",
"//absl/base:log_severity",
"//absl/strings",
diff --git a/absl/log/CMakeLists.txt b/absl/log/CMakeLists.txt
index de2eaf39..4bc6f0d8 100644
--- a/absl/log/CMakeLists.txt
+++ b/absl/log/CMakeLists.txt
@@ -604,7 +604,7 @@ absl_cc_library(
${ABSL_DEFAULT_LINKOPTS}
DEPS
absl::config
- absl::log
+ absl::absl_log
absl::log_severity
absl::optional
absl::strings
diff --git a/absl/log/log_streamer.h b/absl/log/log_streamer.h
index 20327455..2d41a07f 100644
--- a/absl/log/log_streamer.h
+++ b/absl/log/log_streamer.h
@@ -30,7 +30,7 @@
#include "absl/base/config.h"
#include "absl/base/log_severity.h"
-#include "absl/log/log.h"
+#include "absl/log/absl_log.h"
#include "absl/strings/internal/ostringstream.h"
#include "absl/strings/string_view.h"
#include "absl/types/optional.h"
@@ -99,7 +99,7 @@ class LogStreamer final {
that.stream_.reset();
}
LogStreamer& operator=(LogStreamer&& that) {
- LOG_IF(LEVEL(severity_), stream_).AtLocation(file_, line_) << buf_;
+ ABSL_LOG_IF(LEVEL(severity_), stream_).AtLocation(file_, line_) << buf_;
severity_ = that.severity_;
file_ = std::move(that.file_);
line_ = that.line_;
@@ -114,7 +114,7 @@ class LogStreamer final {
//
// Logs this LogStreamer's buffered content as if by LOG.
~LogStreamer() {
- LOG_IF(LEVEL(severity_), stream_.has_value()).AtLocation(file_, line_)
+ ABSL_LOG_IF(LEVEL(severity_), stream_.has_value()).AtLocation(file_, line_)
<< buf_;
}