summaryrefslogtreecommitdiff
path: root/absl/flags/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2020-05-20 00:23:37 -0700
committerGravatar Mark Barolak <mbar@google.com>2020-05-21 10:16:55 -0400
commitcf1a02e2dc5a1bc9d095f4c996306de448ca200f (patch)
tree74cd530ed421fb27a8774a5a11243bd81682ee18 /absl/flags/CMakeLists.txt
parent768eb2ca2857342673fcd462792ce04b8bac3fa3 (diff)
Export of internal Abseil changes
-- 30e5e00a54cabc50118a3e1055826ea02a0d32e4 by Gennadiy Rozental <rogeeff@google.com>: Move flag help into flag_cold section. To facilitate this we set flag help not in a constructor, but during flag registration. This allows us to place flag name as static variable inside non constexpr lambda and invoke it immediately in FlagRegistrar argument location. PiperOrigin-RevId: 312432625 -- efd91b05152b68df648cff5ba38e9669a817c12f by Gennadiy Rozental <rogeeff@google.com>: Make CommandLineFlag public. PiperOrigin-RevId: 312404666 -- dc7f5fb73487766fa8a76d6b97d28116e5334445 by Mark Barolak <mbar@google.com>: Internal change. PiperOrigin-RevId: 312297164 GitOrigin-RevId: 30e5e00a54cabc50118a3e1055826ea02a0d32e4 Change-Id: Ic46ab011bb804645264572caddff0becba5f9170
Diffstat (limited to 'absl/flags/CMakeLists.txt')
-rw-r--r--absl/flags/CMakeLists.txt98
1 files changed, 53 insertions, 45 deletions
diff --git a/absl/flags/CMakeLists.txt b/absl/flags/CMakeLists.txt
index e6b17c9b..6ecf3b48 100644
--- a/absl/flags/CMakeLists.txt
+++ b/absl/flags/CMakeLists.txt
@@ -17,24 +17,16 @@
# Internal-only target, do not depend on directly.
absl_cc_library(
NAME
- flags_internal
- SRCS
- "internal/flag.cc"
+ flags_path_util
HDRS
- "internal/flag.h"
+ "internal/path_util.h"
COPTS
${ABSL_DEFAULT_COPTS}
LINKOPTS
${ABSL_DEFAULT_LINKOPTS}
DEPS
- absl::base
absl::config
- absl::flags_config
- absl::flags_handle
- absl::flags_marshalling
- absl::flags_registry
- absl::synchronization
- absl::meta
+ absl::strings
PUBLIC
)
@@ -59,22 +51,6 @@ absl_cc_library(
PUBLIC
)
-# Internal-only target, do not depend on directly.
-absl_cc_library(
- NAME
- flags_path_util
- HDRS
- "internal/path_util.h"
- COPTS
- ${ABSL_DEFAULT_COPTS}
- LINKOPTS
- ${ABSL_DEFAULT_LINKOPTS}
- DEPS
- absl::config
- absl::strings
- PUBLIC
-)
-
absl_cc_library(
NAME
flags_config
@@ -118,9 +94,7 @@ absl_cc_library(
# Internal-only target, do not depend on directly.
absl_cc_library(
NAME
- flags_handle
- SRCS
- "internal/commandlineflag.cc"
+ flags_commandlineflag_internal
HDRS
"internal/commandlineflag.h"
COPTS
@@ -129,12 +103,25 @@ absl_cc_library(
${ABSL_DEFAULT_LINKOPTS}
DEPS
absl::config
- absl::fast_type_id
absl::core_headers
- absl::optional
- absl::raw_logging_internal
+ absl::fast_type_id
absl::strings
- absl::synchronization
+)
+
+absl_cc_library(
+ NAME
+ flags_commandlineflag
+ SRCS
+ "commandlineflag.cc"
+ HDRS
+ "commandlineflag.h"
+ COPTS
+ ${ABSL_DEFAULT_COPTS}
+ LINKOPTS
+ ${ABSL_DEFAULT_LINKOPTS}
+ DEPS
+ absl::flags_commandlineflag_internal
+ absl::optional
)
# Internal-only target, do not depend on directly.
@@ -150,7 +137,7 @@ absl_cc_library(
LINKOPTS
${ABSL_DEFAULT_LINKOPTS}
DEPS
- absl::flags_handle
+ absl::flags_commandlineflag
)
# Internal-only target, do not depend on directly.
@@ -169,8 +156,8 @@ absl_cc_library(
${ABSL_DEFAULT_LINKOPTS}
DEPS
absl::config
+ absl::flags_commandlineflag
absl::flags_config
- absl::flags_handle
absl::flags_private_handle_accessor
absl::core_headers
absl::raw_logging_internal
@@ -178,6 +165,29 @@ absl_cc_library(
absl::synchronization
)
+# Internal-only target, do not depend on directly.
+absl_cc_library(
+ NAME
+ flags_internal
+ SRCS
+ "internal/flag.cc"
+ HDRS
+ "internal/flag.h"
+ COPTS
+ ${ABSL_DEFAULT_COPTS}
+ LINKOPTS
+ ${ABSL_DEFAULT_LINKOPTS}
+ DEPS
+ absl::base
+ absl::config
+ absl::flags_config
+ absl::flags_marshalling
+ absl::flags_registry
+ absl::synchronization
+ absl::meta
+ PUBLIC
+)
+
absl_cc_library(
NAME
flags
@@ -192,8 +202,8 @@ absl_cc_library(
${ABSL_DEFAULT_LINKOPTS}
DEPS
absl::config
+ absl::flags_commandlineflag
absl::flags_config
- absl::flags_handle
absl::flags_internal
absl::flags_marshalling
absl::flags_registry
@@ -218,10 +228,10 @@ absl_cc_library(
absl::config
absl::flags_config
absl::flags
- absl::flags_handle
- absl::flags_private_handle_accessor
+ absl::flags_commandlineflag
absl::flags_internal
absl::flags_path_util
+ absl::flags_private_handle_accessor
absl::flags_program_name
absl::flags_registry
absl::strings
@@ -264,9 +274,9 @@ absl_cc_library(
absl::core_headers
absl::flags_config
absl::flags
- absl::flags_handle
- absl::flags_private_handle_accessor
+ absl::flags_commandlineflag
absl::flags_internal
+ absl::flags_private_handle_accessor
absl::flags_program_name
absl::flags_registry
absl::flags_usage
@@ -281,13 +291,13 @@ absl_cc_test(
NAME
flags_commandlineflag_test
SRCS
- "internal/commandlineflag_test.cc"
+ "commandlineflag_test.cc"
COPTS
${ABSL_TEST_COPTS}
DEPS
absl::flags
+ absl::flags_commandlineflag
absl::flags_config
- absl::flags_handle
absl::flags_private_handle_accessor
absl::flags_registry
absl::memory
@@ -319,7 +329,6 @@ absl_cc_test(
absl::core_headers
absl::flags
absl::flags_config
- absl::flags_handle
absl::flags_internal
absl::flags_registry
absl::strings
@@ -391,7 +400,6 @@ absl_cc_test(
${ABSL_TEST_COPTS}
DEPS
absl::flags
- absl::flags_handle
absl::flags_marshalling
absl::flags_registry
absl::memory