summaryrefslogtreecommitdiff
path: root/absl/copts/copts.py
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2018-12-16 15:32:37 -0800
committerGravatar Mark Barolak <mbar@google.com>2018-12-17 13:22:17 -0500
commit111ca7060a6ff50115ca85b59f6b5d8c8c5e9105 (patch)
tree5bf21b8c285a3098d34689efe547d77c387beea8 /absl/copts/copts.py
parent389ec3f906f018661a5308458d623d01f96d7b23 (diff)
Export of internal Abseil changes.
-- a2adbf75201f6b7feba929f77dfc4f87f9c1110b by Abseil Team <absl-team@google.com>: This change allows for capturing the address of the mutex from which a call to `Block(...)` could be introducing latency. The attribute is a no-op if the application is not being built with XRay instrumentation. See http://llvm.org/docs/XRay.html for more information about XRay. PiperOrigin-RevId: 225752598 -- 6bc7f25573ddc6711f484dfacab9459f45e0bf42 by Abseil Team <absl-team@google.com>: Update absl/utility/CMakeLists.txt to use new functions i.e. absl_cc_(library|test) PiperOrigin-RevId: 225651883 -- 4acde5e72032f31a26a1ffa53a28f35dbb0bd7d3 by Abseil Team <absl-team@google.com>: Update absl/types/CMakeLists.txt to use new functions i.e. absl_cc_(library|test) PiperOrigin-RevId: 225584788 -- fe2c740d64b17cece25eee4e5d2196a7c059d3e9 by Abseil Team <absl-team@google.com>: Update auto-generated build options files. PiperOrigin-RevId: 225557283 -- cd779dddceeee191ee82deb6b9030c4db288e758 by Jon Cohen <cohenjon@google.com>: Internal change. PiperOrigin-RevId: 225556657 -- 3d56dd132d845930c3fb520a39ee77ecb2430bd2 by Matt Kulukundis <kfm@google.com>: Internal cleanup PiperOrigin-RevId: 225488946 GitOrigin-RevId: a2adbf75201f6b7feba929f77dfc4f87f9c1110b Change-Id: I1b2178e053bdebc8cf3dcb017b0e247619b81a0c
Diffstat (limited to 'absl/copts/copts.py')
-rw-r--r--absl/copts/copts.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/absl/copts/copts.py b/absl/copts/copts.py
index 5870dfce..40a8062f 100644
--- a/absl/copts/copts.py
+++ b/absl/copts/copts.py
@@ -3,7 +3,8 @@
This is the source of truth for Abseil compiler options. To modify Abseil
compilation options:
- (1) Edit the appropriate list in this file.
+ (1) Edit the appropriate list in this file based on the platform the flag is
+ needed on.
(2) Run `<path_to_absl>/copts/generate_copts.py`.
The generated copts are consumed by configure_copts.bzl and
@@ -11,7 +12,6 @@ AbseilConfigureCopts.cmake.
"""
import collections # absl:google-only(used for internal flags)
-
COPT_VARS = {
"GCC_FLAGS": [
"-Wall",