summaryrefslogtreecommitdiff
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2023-02-10 06:31:03 -0800
committerGravatar Copybara-Service <copybara-worker@google.com>2023-02-10 06:31:53 -0800
commitcde2f0eaaed3fb8581511cb5719d39172a5a2d81 (patch)
tree5e1bd18df537626cb1adf6f4a811c643c2ea342e /absl/container/CMakeLists.txt
parentfa4855403cdfb91b9c16f792041258ed819594c1 (diff)
Workaround MSan false positive.
On Linux Kernels >= 5.4 MSan reports a false positive when accessing thread local storage data from loaded libraries. This was reported on Chromium (which on some build configurations uses absl as a dynamic library). More info here: crbug.com/1414573. PiperOrigin-RevId: 508645053 Change-Id: I5d5a97e1ee7230cc23f3934a4ec5594b883918b4
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index 9ba95b32..43d60b9d 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -706,6 +706,7 @@ absl_cc_library(
absl::container_common
absl::container_memory
absl::core_headers
+ absl::dynamic_annotations
absl::endian
absl::hash
absl::hash_policy_traits