summaryrefslogtreecommitdiff
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2021-08-11 11:57:03 -0700
committerGravatar Derek Mauro <dmauro@google.com>2021-08-11 20:41:24 +0000
commitb699707f0bfeae034e36cdfd909b66b0fcab696c (patch)
treec961ce4c7b9a040b47a42abbdabdec10a4d7f043 /absl/container/CMakeLists.txt
parent8e088c5f3c290c5ac53dd5010fd501d80b483115 (diff)
Export of internal Abseil changes
-- 228b5878d7a994656f383666cfaee34e33e0b09b by Abseil Team <absl-team@google.com>: Add element_type typedef to match std::span<T> PiperOrigin-RevId: 390186160 -- c91d96c88c60be793c525158f76dfcaa5e32d161 by Abseil Team <absl-team@google.com>: Rollback change to only hide retired flags if human-readable output is requested PiperOrigin-RevId: 390183146 -- 170192c10ef8d513de80f29298ce93eeccc3712c by Abseil Team <absl-team@google.com>: Move alignas(16) before ABSL_CONST_INIT and ABSL_DLL. PiperOrigin-RevId: 390182845 -- 77a5ee5081c81cef625fac7bbcf993cc028b32ed by Evan Brown <ezb@google.com>: Use simple SlotOffset and AllocSize logic instead of container_internal::Layout in order to save linker input size for non-opt and sanitizer builds. In opt mode, all of this logic is inlined so we don't save linker input size in opt mode. PiperOrigin-RevId: 389914594 GitOrigin-RevId: 228b5878d7a994656f383666cfaee34e33e0b09b Change-Id: I3b904068687574931d8390071b322c0c3c083283
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index 91c40154..691a05c0 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -666,7 +666,6 @@ absl_cc_library(
absl::hash_policy_traits
absl::hashtable_debug_hooks
absl::have_sse
- absl::layout
absl::memory
absl::meta
absl::optional