summaryrefslogtreecommitdiff
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2019-08-09 11:54:24 -0700
committerGravatar vslashg <gfalcon@google.com>2019-08-09 15:11:33 -0400
commit4ef574064e75b86f115549e9eb4c7e806781b3ab (patch)
treebcd527aff8b7d1f2cf673646e542ad739b8aaba7 /absl/container/CMakeLists.txt
parent9ee91d3e430fb33a4590486573792eb0fa146c2d (diff)
Export of internal Abseil changes
-- 3dbb096e4662311f81df1017a8e0975e903936cf by Derek Mauro <dmauro@google.com>: Document and workaround a known MSVC bug doing constexpr pointer arithmetic PiperOrigin-RevId: 262604652 -- b5fa7f1a0c776f6ba20d52772a1679ec42ad21fd by Derek Mauro <dmauro@google.com>: Fix typo in macos_xcode_bazel.sh PiperOrigin-RevId: 262591285 -- 89dd77ab5bb44d76b6cb6b2f288e21536e16a85a by Derek Mauro <dmauro@google.com>: Internal change PiperOrigin-RevId: 262582747 -- 32295ed9a0c6c8ab143a912194040eede05d3ea3 by Abseil Team <absl-team@google.com>: Internal change PiperOrigin-RevId: 262569140 -- 7f0f5b94197369228024529022d727439d2c894f by Abseil Team <absl-team@google.com>: Internal change PiperOrigin-RevId: 262563554 -- 314aed043639abbd221074125c57b7c68616de7e by Derek Mauro <dmauro@google.com>: Release absl::btree PiperOrigin-RevId: 262553526 -- 72b44056c6ce9000c4a6cd9aec58b82067c82a13 by CJ Johnson <johnsoncj@google.com>: Internal change PiperOrigin-RevId: 262421185 -- 4e2c12151edf534f929e8e810f1334073f90489a by Abseil Team <absl-team@google.com>: Update documentation to make it less likely for users to write `Hours(24)` without considering using civil dates instead. PiperOrigin-RevId: 262420758 -- 92b85b9573e800bd96b019408eefbc5ce4f68780 by Derek Mauro <dmauro@google.com>: Add the ability to override the bazel version in the macos_xcode_bazel.sh test script. PiperOrigin-RevId: 262412063 GitOrigin-RevId: 3dbb096e4662311f81df1017a8e0975e903936cf Change-Id: I423b2b829dc0c5f814e37bec4d68c7470f43f041
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt62
1 files changed, 62 insertions, 0 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index 7988b12f..6cabe0c9 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -25,6 +25,68 @@ absl_cc_library(
absl_cc_library(
NAME
+ btree
+ HDRS
+ "btree_map.h"
+ "btree_set.h"
+ "internal/btree.h"
+ "internal/btree_container.h"
+ COPTS
+ ${ABSL_DEFAULT_COPTS}
+ LINKOPTS
+ ${ABSL_DEFAULT_LINKOPTS}
+ DEPS
+ absl::container_common
+ absl::compare
+ absl::compressed_tuple
+ absl::container_memory
+ absl::core_headers
+ absl::layout
+ absl::memory
+ absl::strings
+ absl::throw_delegate
+ absl::type_traits
+ absl::utility
+)
+
+absl_cc_library(
+ NAME
+ btree_test_common
+ hdrs
+ "btree_test.h"
+ COPTS
+ ${ABSL_TEST_COPTS}
+ LINKOPTS
+ ${ABSL_DEFAULT_LINKOPTS}
+ DEPS
+ absl::btree
+ absl::flat_hash_set
+ absl::strings
+ absl::time
+ TESTONLY
+)
+
+absl_cc_test(
+ NAME
+ btree_test
+ SRCS
+ "btree_test.cc"
+ DEPS
+ absl::base
+ absl::btree
+ absl::btree_test_common
+ absl::compare
+ absl::counting_allocator
+ absl::flags
+ absl::hash_testing
+ absl::strings
+ absl::test_instance_tracker
+ absl::type_traits
+ gmock_main
+)
+
+absl_cc_library(
+ NAME
compressed_tuple
HDRS
"internal/compressed_tuple.h"