summaryrefslogtreecommitdiff
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Greg Falcon <gfalcon@google.com>2022-05-18 10:01:14 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2022-05-18 10:01:57 -0700
commit3e04aade4e7a53aebbbed1a1268117f1f522bfb0 (patch)
treea474a12423cb60a61e30ec03a3a9970e64ece23e /absl/container/CMakeLists.txt
parent9df63a8beaae53802109346f0a20328140a7cb8e (diff)
Replace direct uses of __builtin_prefetch from SwissTable with the wrapper functions.
Add a new (internal) feature test macro to detect whether the wrappers are no-ops on a given platform. Note that one-arg __builtin_prefetch(x) is equivalent to __builtin_prefetch(x, 0, 3), per `man BUILTIN_PREFETCH(3)` and gcc docs. PiperOrigin-RevId: 449508660 Change-Id: I144e750205eec0c956d8dd62bc72e10bdb87c4f7
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index aad69fa2..9b5c59a4 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -681,6 +681,7 @@ absl_cc_library(
absl::memory
absl::meta
absl::optional
+ absl::prefetch
absl::utility
absl::hashtablez_sampler
PUBLIC
@@ -702,6 +703,7 @@ absl_cc_test(
absl::base
absl::config
absl::core_headers
+ absl::prefetch
absl::raw_logging_internal
absl::strings
GTest::gmock_main