summaryrefslogtreecommitdiff
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Evan Brown <ezb@google.com>2023-04-12 09:57:09 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2023-04-12 09:57:55 -0700
commit2126f023986070c518d676a6a116124fc0c5ba00 (patch)
treee873ed0190e19a5ba07146c13b399faf5ad006de /absl/container/CMakeLists.txt
parentcb204d6d9c3f2066580e606bcbe54e3383791d5f (diff)
In debug mode, detect cases of btree comparators that violate transitivity, i.e. comp(A,B) && comp(B,C) -> comp(A,C).
When inserting a new element, we verify that the key is ordered correctly with respect to all the other values on the node, which can be done in constant time. PiperOrigin-RevId: 523729309 Change-Id: Idb5a5912a9aa5411d086cb9fa76791523046778a
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index 43d60b9d..3c48270b 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -80,6 +80,7 @@ absl_cc_test(
absl::counting_allocator
absl::flags
absl::hash_testing
+ absl::optional
absl::random_random
absl::raw_logging_internal
absl::strings