summaryrefslogtreecommitdiff
path: root/absl/base/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2019-07-30 07:36:25 -0700
committerGravatar Andy Soffer <asoffer@google.com>2019-07-30 13:27:17 -0400
commit52e88ee56b72cf32bc66534d942c7398ce481331 (patch)
treea63d66a7ba3a560cb6154e6f5e4d4fc7419dc162 /absl/base/CMakeLists.txt
parent36d37ab992038f52276ca66b9da80c1cf0f57dc2 (diff)
Export of internal Abseil changes.
-- 788c948f698afe5998738cbb40b0629668640d73 by Derek Mauro <dmauro@google.com>: Add an empty raw_logging_internal library. The raw_logging sources will eventually migrate here. This target will only contain internal sources. Abseil compatibility guidelines require users not depend on internals. https://abseil.io/about/compatibility PiperOrigin-RevId: 260712817 -- 8ea947ec54f47fb02e97597d243cb63aa4c5fe0b by Abseil Team <absl-team@google.com>: Fixed an incorrect version number test for optional,etc. availability in iOS. Added tests for watchOS and tvOS. PiperOrigin-RevId: 260490390 -- 53af0544277dc3020b81d16ce110e7bc89f5cf6e by Jorg Brown <jorg@google.com>: Test the error-string path a bit more. PiperOrigin-RevId: 260175886 GitOrigin-RevId: 788c948f698afe5998738cbb40b0629668640d73 Change-Id: I366b73331857dc5a1db843b650c2ba27a69a141e
Diffstat (limited to 'absl/base/CMakeLists.txt')
-rw-r--r--absl/base/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/absl/base/CMakeLists.txt b/absl/base/CMakeLists.txt
index 8417556c..9ff80738 100644
--- a/absl/base/CMakeLists.txt
+++ b/absl/base/CMakeLists.txt
@@ -34,7 +34,14 @@ absl_cc_library(
absl::core_headers
COPTS
${ABSL_DEFAULT_COPTS}
-)
+)
+
+absl_cc_library(
+ NAME
+ raw_logging_internal
+ COPTS
+ ${ABSL_DEFAULT_COPTS}
+)
absl_cc_library(
NAME