summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2020-07-13 13:22:02 -0700
committerGravatar vslashg <gfalcon@google.com>2020-07-15 14:12:16 -0400
commitf624790b7f76ab92fed5ae966abb99a0d455c96f (patch)
treed1550e3e5b58a3b0c0c0c9a69134e71da8d3f22c /CMakeLists.txt
parent55c04eb9203a93db1c0816adddf3182b45da5384 (diff)
Export of internal Abseil changes
-- 4fc38390e66394e51ef4637ca0778f929017b4c8 by Gennadiy Rozental <rogeeff@google.com>: Internal Change PiperOrigin-RevId: 321020681 -- 880d1c1cb7590e7265e21afe32edde473ef830d4 by Derek Mauro <dmauro@google.com>: Decrease number of threads in thread_identity_test to hopefully prevent test timeouts PiperOrigin-RevId: 321019403 GitOrigin-RevId: 4fc38390e66394e51ef4637ca0778f929017b4c8 Change-Id: Id8175bae6e490277d663d76fff9c06353b8c7f05
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 95880c20..54ce4994 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,6 +30,9 @@ cmake_policy(SET CMP0057 NEW)
# Project version variables are the empty string if version is unspecified
cmake_policy(SET CMP0048 NEW)
+# option() honor variables
+cmake_policy(SET CMP0077 NEW)
+
project(absl CXX)
# Output directory is correct by default for most build setups. However, when
@@ -41,9 +44,9 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
# when absl is included as subproject (i.e. using add_subdirectory(abseil-cpp))
# in the source tree of a project that uses it, install rules are disabled.
if(NOT "^${CMAKE_SOURCE_DIR}$" STREQUAL "^${PROJECT_SOURCE_DIR}$")
- set(ABSL_ENABLE_INSTALL FALSE)
+ option(ABSL_ENABLE_INSTALL "Enable install rule" OFF)
else()
- set(ABSL_ENABLE_INSTALL TRUE)
+ option(ABSL_ENABLE_INSTALL "Enable install rule" ON)
endif()
list(APPEND CMAKE_MODULE_PATH