summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Derek Mauro <dmauro@google.com>2022-09-07 06:58:32 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2022-09-07 06:59:16 -0700
commitea9c8ff5789bd3ff3ae842903f198700e4e1a11f (patch)
tree50f914a1b8dd423a815a301da3419aa994b90885 /CMakeLists.txt
parent308bbf300fe9332130f4784c7a91fa2ad707d6e4 (diff)
CMake: Require at least CMake 3.10
This is the current minimum according to https://github.com/google/oss-policies-info/blob/main/foundational-cxx-support-matrix.md PiperOrigin-RevId: 472714045 Change-Id: I5930bbbc4eec4644d22bba703957d1764c2e76be
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 016dd917..3b67d8fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,12 +14,9 @@
# limitations under the License.
#
-# Most widely used distributions have cmake 3.5 or greater available as of March
-# 2019. A notable exception is RHEL-7 (CentOS7). You can install a current
-# version of CMake by first installing Extra Packages for Enterprise Linux
-# (https://fedoraproject.org/wiki/EPEL#Extra_Packages_for_Enterprise_Linux_.28EPEL.29)
-# and then issuing `yum install cmake3` on the command line.
-cmake_minimum_required(VERSION 3.5)
+# https://github.com/google/oss-policies-info/blob/main/foundational-cxx-support-matrix.md
+# As of 2022-09-06, CMake 3.10 is the minimum supported version.
+cmake_minimum_required(VERSION 3.10)
# Compiler id for Apple Clang is now AppleClang.
if (POLICY CMP0025)