summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar WolverinDEV <git@mcgalaxy.de>2021-03-30 18:44:11 +0200
committerGravatar GitHub <noreply@github.com>2021-03-30 12:44:11 -0400
commit2d418976ef0a1765798afd8e69538308d7b15242 (patch)
treeee78609168663af7228958df2a937f4ef60f953a /CMakeLists.txt
parent9fe35195495da41ab8f307abb61ed4169afa396e (diff)
Allowing to change the MSVC runtime (#921)
* Allowing to change the MSVC runtime with the CMake option CMAKE_MSVC_RUNTIME_LIBRARY introduced in 3.15 * Update CMakeLists.txt Capitalize MSVC Co-authored-by: Derek Mauro <761129+derekmauro@users.noreply.github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e09e335c..d0c6e608 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,11 @@ if (POLICY CMP0077)
cmake_policy(SET CMP0077 NEW)
endif (POLICY CMP0077)
+# Allow the user to specify the MSVC runtime
+if (POLICY CMP0091)
+ cmake_policy(SET CMP0091 NEW)
+endif (POLICY CMP0091)
+
# Set BUILD_TESTING to OFF by default.
# This must come before the project() and include(CTest) lines.
OPTION(BUILD_TESTING "Build tests" OFF)