summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2020-05-28 12:55:24 -0700
committerGravatar Derek Mauro <dmauro@google.com>2020-05-28 15:58:09 -0400
commit2069dc796aa255f7c82861c6e83b82d001ceef4a (patch)
treea380c9d6c1890b2b67cd77625d404ac9e141a415 /CMakeLists.txt
parent4832bf6bf27b873cffc020f4b4f85634d11c57be (diff)
Export of internal Abseil changes
-- cb68208c1ae9ca45ce48bf2b7e6cc46592a3b22d by Derek Mauro <dmauro@google.com>: Update GoogleTest dependency and use it to mark a parameterized test as possibly unused. PiperOrigin-RevId: 313643136 -- 24f61fe25e943e78f8a1fd014c89516776943170 by Derek Mauro <dmauro@google.com>: Internal change PiperOrigin-RevId: 313636155 -- 36c453ddf04791f8cf3d14673bacd7bbd98911fd by Gennadiy Rozental <rogeeff@google.com>: Address sanitizer should not use DYNAMIC_ANNOTATIONS_ENABLED=1 PiperOrigin-RevId: 313635651 -- 7a7a3e3888ac8ae366572ea0a2a1c62dc669cec7 by Abseil Team <absl-team@google.com>: CMake: don't attempt to use googletest unless ABSL_RUN_TESTS==true. Fixes: https://github.com/abseil/abseil-cpp/issues/690 PiperOrigin-RevId: 313477705 GitOrigin-RevId: cb68208c1ae9ca45ce48bf2b7e6cc46592a3b22d Change-Id: Ief7b31b53cdf3f79518b767d882960c1636aad23
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47670454..c654c892 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -99,10 +99,8 @@ if(${ABSL_RUN_TESTS})
# on the command line
include(CTest)
enable_testing()
-endif()
-## check targets
-if(BUILD_TESTING)
+ ## check targets
if (NOT ABSL_USE_EXTERNAL_GOOGLETEST)
set(absl_gtest_build_dir ${CMAKE_BINARY_DIR}/googletest-build)
if(${ABSL_USE_GOOGLETEST_HEAD})