summaryrefslogtreecommitdiff
path: root/CMake/AbseilHelpers.cmake
diff options
context:
space:
mode:
authorGravatar Derek Mauro <761129+derekmauro@users.noreply.github.com>2021-04-20 12:55:14 -0400
committerGravatar GitHub <noreply@github.com>2021-04-20 12:55:14 -0400
commite1d388e7e74803050423d035e4374131b9b57919 (patch)
tree36f8dd29bcb24c0babc80ab7372848a8f21542a7 /CMake/AbseilHelpers.cmake
parent997aaf3a28308eba1b9156aa35ab7bca9688e9f6 (diff)
Abseil LTS 20210324, Patch 1 (#943)20210324.1
* Add missing `add_subdirectory()` call for "cleanup" (#925) Since `absl::Cleanup` is now public, it should also be included in the `absl/CMakeLists.txt` file. Signed-off-by: Christian Blichmann <cblichmann@google.com> * Correctly install pkgconfig files under CMAKE_INSTALL_LIBDIR Fixes #931 PiperOrigin-RevId: 366816645 * AbseilConfigureCopts.cmake: fix AppleClang detection restore use of MATCHES in comparison with "Clang"; this was lost in: commit 22771d471930ce88e1e75d0ca9dd8c65a7b0f895 ... 24e1f5f72756046f5265abf618e951c341f09b8d by Derek Mauro <dmauro@google.com>: Fixes failing CMake string comparisons https://cmake.org/cmake/help/latest/policy/CMP0054.html fixes: CMake Warning at absl/copts/AbseilConfigureCopts.cmake:61 (message): Unknown compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/c++. Building with no default flags Fixes #930 PiperOrigin-RevId: 366879337 * Increment SOVERSION to 2103.0.1 Co-authored-by: Christian Blichmann <cblichmann@users.noreply.github.com> Co-authored-by: Abseil Team <absl-team@google.com>
Diffstat (limited to 'CMake/AbseilHelpers.cmake')
-rw-r--r--CMake/AbseilHelpers.cmake4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMake/AbseilHelpers.cmake b/CMake/AbseilHelpers.cmake
index 70eaa4ca..54fb8df3 100644
--- a/CMake/AbseilHelpers.cmake
+++ b/CMake/AbseilHelpers.cmake
@@ -181,7 +181,7 @@ Requires:${PC_DEPS}\n\
Libs: -L\${libdir} $<JOIN:${ABSL_CC_LIB_LINKOPTS}, > $<$<NOT:$<BOOL:${ABSL_CC_LIB_IS_INTERFACE}>>:-labsl_${_NAME}>\n\
Cflags: -I\${includedir}${PC_CFLAGS}\n")
INSTALL(FILES "${CMAKE_BINARY_DIR}/lib/pkgconfig/absl_${_NAME}.pc"
- DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/pkgconfig")
+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
endif()
endif()
@@ -263,7 +263,7 @@ Cflags: -I\${includedir}${PC_CFLAGS}\n")
if(ABSL_ENABLE_INSTALL)
set_target_properties(${_NAME} PROPERTIES
OUTPUT_NAME "absl_${_NAME}"
- SOVERSION "2103.0.0"
+ SOVERSION "2103.0.1"
)
endif()
else()