summaryrefslogtreecommitdiff
path: root/CMake/AbseilDll.cmake
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2024-05-31 14:31:21 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2024-05-31 14:32:29 -0700
commitd06b82773e2306a99a8971934fb5845d5c04a170 (patch)
tree6af256205759c905b44577555da97a6db6a881f1 /CMake/AbseilDll.cmake
parent0d9746acbd4b5c0b46d299a3f0909bcc23540123 (diff)
Move SOVERSION to global CMakeLists, apply SOVERSION to DLL
So that multiple LTS builds can co-exist. PiperOrigin-RevId: 639154515 Change-Id: Id34d6fbef823151a4f3c73cf7b9b340257eadd63
Diffstat (limited to 'CMake/AbseilDll.cmake')
-rw-r--r--CMake/AbseilDll.cmake5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMake/AbseilDll.cmake b/CMake/AbseilDll.cmake
index 88e1d35f..828cc347 100644
--- a/CMake/AbseilDll.cmake
+++ b/CMake/AbseilDll.cmake
@@ -827,7 +827,10 @@ function(absl_make_dll)
${_dll_libs}
${ABSL_DEFAULT_LINKOPTS}
)
- set_property(TARGET ${_dll} PROPERTY LINKER_LANGUAGE "CXX")
+ set_target_properties(${_dll} PROPERTIES
+ LINKER_LANGUAGE "CXX"
+ SOVERSION ${ABSL_SOVERSION}
+ )
target_include_directories(
${_dll}
PUBLIC