summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2018-10-31 08:10:03 -0700
committerGravatar Matt Calabrese <calabrese@x.team>2018-10-31 11:12:18 -0400
commitcc8dcd307b76a575d2e3e0958a4fe4c7193c2f68 (patch)
tree3b035beefd2dd9385f83b949ee50392c9be37e76
parenta705aa78dc76fc5c79d501e61dcc077eca68a8a4 (diff)
Export of internal Abseil changes.
-- 9e8aa654630015ea8221703b0ea10dd1a47a848f by Abseil Team <absl-team@google.com>: Fix typo PiperOrigin-RevId: 219474910 -- b1621572fb5a326642766f9f0f16abc3620dd6e8 by Xiaoyi Zhang <zhangxy@google.com>: Applies https://github.com/abseil/abseil-cpp/pull/194 to fix raw_hash_map build issues for Windows VS 15.8. PiperOrigin-RevId: 219473484 -- a61df296bc5449261c6deccb6410df83d560d210 by Jon Cohen <cohenjon@google.com>: Remove reference to ABSL_COMPILE_CXXFLAGS in our cmakelists files. It wasn't used, but we will soon instead use an INERFACE target with target_compile_options for the compile options needed for Abseil. PiperOrigin-RevId: 219352641 -- 0d9536a26c03229df3e782e78a8211e450259af2 by Abseil Team <absl-team@google.com>: Add missing dependencies on base:core_headers PiperOrigin-RevId: 219320098 -- 5693e836e4ec4ce23315f3a7846c12c64cf3d5ab by Abseil Team <absl-team@google.com>: Remove dynamic_annotations from core_headers, and add core_headers to CMakeLists. PiperOrigin-RevId: 219306959 GitOrigin-RevId: 9e8aa654630015ea8221703b0ea10dd1a47a848f Change-Id: Ie52b9fa7ab1285b6846ceea5503caf744e7303d8
-rw-r--r--CMake/AbseilHelpers.cmake7
-rw-r--r--absl/base/BUILD.bazel1
-rw-r--r--absl/base/CMakeLists.txt23
-rw-r--r--absl/debugging/BUILD.bazel1
-rw-r--r--absl/hash/hash.h2
-rw-r--r--absl/types/BUILD.bazel1
6 files changed, 29 insertions, 6 deletions
diff --git a/CMake/AbseilHelpers.cmake b/CMake/AbseilHelpers.cmake
index 96813b08..d4870365 100644
--- a/CMake/AbseilHelpers.cmake
+++ b/CMake/AbseilHelpers.cmake
@@ -48,7 +48,7 @@ function(absl_library)
add_library(${_NAME} STATIC ${ABSL_LIB_SOURCES})
- target_compile_options(${_NAME} PRIVATE ${ABSL_COMPILE_CXXFLAGS} ${ABSL_LIB_PRIVATE_COMPILE_FLAGS})
+ target_compile_options(${_NAME} PRIVATE ${ABSL_LIB_PRIVATE_COMPILE_FLAGS})
target_link_libraries(${_NAME} PUBLIC ${ABSL_LIB_PUBLIC_LIBRARIES})
target_include_directories(${_NAME}
PUBLIC ${ABSL_COMMON_INCLUDE_DIRS} ${ABSL_LIB_PUBLIC_INCLUDE_DIRS}
@@ -140,9 +140,8 @@ function(absl_cc_library)
target_sources(${_NAME} PRIVATE ${ABSL_CC_LIB_SRCS} ${ABSL_CC_LIB_HDRS})
target_include_directories(${_NAME}
PUBLIC ${ABSL_COMMON_INCLUDE_DIRS})
- # TODO(rongjiecomputer): Revisit ABSL_COMPILE_CXXFLAGS when fixing GH#123
target_compile_options(${_NAME}
- PRIVATE ${ABSL_COMPILE_CXXFLAGS} ${ABSL_CC_LIB_COPTS})
+ PRIVATE ${ABSL_CC_LIB_COPTS})
target_link_libraries(${_NAME}
PUBLIC ${ABSL_CC_LIB_DEPS}
PRIVATE ${ABSL_CC_LIB_LINKOPTS}
@@ -245,7 +244,7 @@ function(absl_test)
add_executable(${_NAME}_bin ${ABSL_TEST_SOURCES})
- target_compile_options(${_NAME}_bin PRIVATE ${ABSL_COMPILE_CXXFLAGS} ${ABSL_TEST_PRIVATE_COMPILE_FLAGS})
+ target_compile_options(${_NAME}_bin PRIVATE ${ABSL_TEST_PRIVATE_COMPILE_FLAGS})
target_link_libraries(${_NAME}_bin PUBLIC ${ABSL_TEST_PUBLIC_LIBRARIES} ${ABSL_TEST_COMMON_LIBRARIES})
target_include_directories(${_NAME}_bin
PUBLIC ${ABSL_COMMON_INCLUDE_DIRS} ${ABSL_TEST_PUBLIC_INCLUDE_DIRS}
diff --git a/absl/base/BUILD.bazel b/absl/base/BUILD.bazel
index f7d81013..9b86ce77 100644
--- a/absl/base/BUILD.bazel
+++ b/absl/base/BUILD.bazel
@@ -75,7 +75,6 @@ cc_library(
copts = ABSL_DEFAULT_COPTS,
deps = [
":config",
- ":dynamic_annotations",
],
)
diff --git a/absl/base/CMakeLists.txt b/absl/base/CMakeLists.txt
index 202003e6..3c580d43 100644
--- a/absl/base/CMakeLists.txt
+++ b/absl/base/CMakeLists.txt
@@ -130,6 +130,29 @@ absl_library(
absl_cc_library(
NAME
+ config
+ HDRS
+ "config.h"
+ "policy_checks.h"
+ PUBLIC
+)
+
+absl_cc_library(
+ NAME
+ core_headers
+ HDRS
+ "attributes.h"
+ "macros.h"
+ "optimization.h"
+ "port.h"
+ "thread_annotations.h"
+ DEPS
+ absl::config
+ PUBLIC
+)
+
+absl_cc_library(
+ NAME
spinlock_wait
SRCS
"internal/spinlock_wait.cc"
diff --git a/absl/debugging/BUILD.bazel b/absl/debugging/BUILD.bazel
index e1e7fced..a8ebaea4 100644
--- a/absl/debugging/BUILD.bazel
+++ b/absl/debugging/BUILD.bazel
@@ -149,6 +149,7 @@ cc_library(
copts = ABSL_DEFAULT_COPTS,
deps = [
"//absl/base",
+ "//absl/base:core_headers",
"//absl/base:dynamic_annotations",
],
)
diff --git a/absl/hash/hash.h b/absl/hash/hash.h
index 8cbb19e2..36c7c2b3 100644
--- a/absl/hash/hash.h
+++ b/absl/hash/hash.h
@@ -98,7 +98,7 @@ namespace absl {
// * absl::string_view
// * absl::InlinedVector
// * absl::FixedArray
-// * absl::unit128
+// * absl::uint128
// * absl::Time, absl::Duration, and absl::TimeZone
//
// Note: the list above is not meant to be exhaustive. Additional type support
diff --git a/absl/types/BUILD.bazel b/absl/types/BUILD.bazel
index 32f690c9..43899ca7 100644
--- a/absl/types/BUILD.bazel
+++ b/absl/types/BUILD.bazel
@@ -168,6 +168,7 @@ cc_library(
deps = [
":bad_optional_access",
"//absl/base:config",
+ "//absl/base:core_headers",
"//absl/memory",
"//absl/meta:type_traits",
"//absl/utility",