summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Derek Mauro <761129+derekmauro@users.noreply.github.com>2024-01-16 13:30:44 -0500
committerGravatar GitHub <noreply@github.com>2024-01-16 13:30:44 -0500
commitad73c6dc1a253203c1c8b529cda18f2138d49df0 (patch)
tree3e20942196480e832a94e060f48f0ba1552049c3
parent10f3e6117b1154ca8e7e744809d82988f0ff481d (diff)
Apply LTS transformations for 20240116 LTS branch (#1599)20240116.rc1
-rw-r--r--CMake/AbseilHelpers.cmake2
-rw-r--r--CMakeLists.txt14
-rw-r--r--MODULE.bazel2
-rw-r--r--absl/base/config.h4
-rw-r--r--absl/base/options.h4
5 files changed, 8 insertions, 18 deletions
diff --git a/CMake/AbseilHelpers.cmake b/CMake/AbseilHelpers.cmake
index bd1c71b0..c53b3584 100644
--- a/CMake/AbseilHelpers.cmake
+++ b/CMake/AbseilHelpers.cmake
@@ -298,7 +298,7 @@ Cflags: -I\${includedir}${PC_CFLAGS}\n")
if(ABSL_ENABLE_INSTALL)
set_target_properties(${_NAME} PROPERTIES
OUTPUT_NAME "absl_${_NAME}"
- SOVERSION 0
+ SOVERSION "2401.0.0"
)
endif()
else()
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 87f8ae82..194f8708 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,7 @@ if (POLICY CMP0141)
cmake_policy(SET CMP0141 NEW)
endif (POLICY CMP0141)
-project(absl LANGUAGES CXX)
+project(absl LANGUAGES CXX VERSION 20240116)
include(CTest)
# Output directory is correct by default for most build setups. However, when
@@ -186,17 +186,7 @@ endif()
add_subdirectory(absl)
if(ABSL_ENABLE_INSTALL)
- # absl:lts-remove-begin(system installation is supported for LTS releases)
- # We don't support system-wide installation
- list(APPEND SYSTEM_INSTALL_DIRS "/usr/local" "/usr" "/opt/" "/opt/local" "c:/Program Files/${PROJECT_NAME}")
- if(NOT DEFINED CMAKE_INSTALL_PREFIX OR CMAKE_INSTALL_PREFIX IN_LIST SYSTEM_INSTALL_DIRS)
- message(WARNING "\
- The default and system-level install directories are unsupported except in LTS \
- releases of Abseil. Please set CMAKE_INSTALL_PREFIX to install Abseil in your \
- source or build tree directly.\
- ")
- endif()
- # absl:lts-remove-end
+
# install as a subdirectory only
install(EXPORT ${PROJECT_NAME}Targets
diff --git a/MODULE.bazel b/MODULE.bazel
index 18190e8e..efbc88b2 100644
--- a/MODULE.bazel
+++ b/MODULE.bazel
@@ -16,7 +16,7 @@
module(
name = "abseil-cpp",
- version = "head",
+ version = "20240116.0",
compatibility_level = 1,
)
diff --git a/absl/base/config.h b/absl/base/config.h
index 0fb66927..762bb7f7 100644
--- a/absl/base/config.h
+++ b/absl/base/config.h
@@ -117,8 +117,8 @@
//
// LTS releases can be obtained from
// https://github.com/abseil/abseil-cpp/releases.
-#undef ABSL_LTS_RELEASE_VERSION
-#undef ABSL_LTS_RELEASE_PATCH_LEVEL
+#define ABSL_LTS_RELEASE_VERSION 20240116
+#define ABSL_LTS_RELEASE_PATCH_LEVEL 0
// Helper macro to convert a CPP variable to a string literal.
#define ABSL_INTERNAL_DO_TOKEN_STR(x) #x
diff --git a/absl/base/options.h b/absl/base/options.h
index a169658f..d7bf8cff 100644
--- a/absl/base/options.h
+++ b/absl/base/options.h
@@ -225,8 +225,8 @@
// be changed to a new, unique identifier name. In particular "head" is not
// allowed.
-#define ABSL_OPTION_USE_INLINE_NAMESPACE 0
-#define ABSL_OPTION_INLINE_NAMESPACE_NAME head
+#define ABSL_OPTION_USE_INLINE_NAMESPACE 1
+#define ABSL_OPTION_INLINE_NAMESPACE_NAME lts_20240116
// ABSL_OPTION_HARDENED
//