summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2022-02-07 11:54:48 -0500
committerGravatar Benjamin Barenblat <bbaren@google.com>2022-02-07 11:54:48 -0500
commit98c32dfeb7a0ad82925d2189f5a5af78f7832aa4 (patch)
treeff589f87b14abaa88098fcd6643fff83b2ad08b6
parent4cc4b43a94261c5eab628b57d013c6eea78bb496 (diff)
Disable a multiarch-hostile test on armhf/armel20210324.2-2
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/arm-multiarch.diff25
-rw-r--r--debian/patches/series1
3 files changed, 33 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index a4fd9c54..9c58851f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+abseil (0~20210324.2-2) unstable; urgency=medium
+
+ * Disable a test that doesn’t play well with multiarch on armel and
+ armhf.
+
+ -- Benjamin Barenblat <bbaren@debian.org> Mon, 07 Feb 2022 11:54:21 -0500
+
abseil (0~20210324.2-1) experimental; urgency=medium
* New upstream release.
diff --git a/debian/patches/arm-multiarch.diff b/debian/patches/arm-multiarch.diff
new file mode 100644
index 00000000..c976f730
--- /dev/null
+++ b/debian/patches/arm-multiarch.diff
@@ -0,0 +1,25 @@
+From: Benjamin Barenblat <bbaren@google.com>
+Subject: Disable SysinfoTest.NominalCPUFrequency on armel/armhf
+
+NominalCPUFrequency has different behavior on 32-bit and 64-bit ARM
+kernels. The Debian arm64 buildds assume they can build 32-bit ARM
+packages, but if they do, the NominalCPUFrequency test will fail.
+Disable the test when building for 32-bit ARM.
+
+--- a/absl/base/internal/sysinfo_test.cc
++++ b/absl/base/internal/sysinfo_test.cc
+@@ -43,7 +43,13 @@
+ // POWER is particularly problematic here; some Linux kernels expose the CPU
+ // frequency, while others do not. Since we can't predict a priori what a given
+ // machine is going to do, just disable this test on POWER on Linux.
++//
++// Debian also disables this test on armel and armhf, since tests for those
++// platforms could either be run on a 32-bit ARM system (where
++// NominalCPUFrequency returns a reasonable value) or a 64-bit ARM system (where
++// it does not).
+-#if !(defined(__linux) && (defined(__ppc64__) || defined(__PPC64__)))
++#if !(defined(__linux) && \
++ (defined(__ppc64__) || defined(__PPC64__) || defined(__arm__)))
+ TEST(SysinfoTest, NominalCPUFrequency) {
+ // Linux only exposes the CPU frequency on certain architectures, and
+ // Emscripten doesn't expose it at all.
diff --git a/debian/patches/series b/debian/patches/series
index e3ac2bd2..f68ea75c 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,5 +1,6 @@
configure.diff
latomic.diff
+arm-multiarch.diff
empty-flags-library.diff
cordrepring-typo.diff
thumb-function-bounds.diff