summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Russell Johnston <rpjohnst@gmail.com>2022-10-15 11:14:56 -0700
committerGravatar Russell Johnston <rpjohnst@gmail.com>2022-10-15 11:14:56 -0700
commit8bf19a07e068b17c2bc2a32aed0ba6d48a80411f (patch)
tree604c98ff3e0f4d9959cea5220112f0bbc79a7a94
parent5fa65f28e46e86c44966a1ca8a727a329d9c1ff8 (diff)
Use the `-l` form for MinGW-specific link dependencies
This corrects the generated .pc files, so these libs match the other libs already included there.
-rw-r--r--absl/base/CMakeLists.txt2
-rw-r--r--absl/debugging/CMakeLists.txt2
-rw-r--r--absl/random/CMakeLists.txt2
3 files changed, 3 insertions, 3 deletions
diff --git a/absl/base/CMakeLists.txt b/absl/base/CMakeLists.txt
index 5c46ba32..26e2b48a 100644
--- a/absl/base/CMakeLists.txt
+++ b/absl/base/CMakeLists.txt
@@ -201,7 +201,7 @@ absl_cc_library(
LINKOPTS
${ABSL_DEFAULT_LINKOPTS}
$<$<BOOL:${LIBRT}>:-lrt>
- $<$<BOOL:${MINGW}>:"advapi32">
+ $<$<BOOL:${MINGW}>:-ladvapi32>
DEPS
absl::atomic_hook
absl::base_internal
diff --git a/absl/debugging/CMakeLists.txt b/absl/debugging/CMakeLists.txt
index 051e7017..e823f15b 100644
--- a/absl/debugging/CMakeLists.txt
+++ b/absl/debugging/CMakeLists.txt
@@ -62,7 +62,7 @@ absl_cc_library(
${ABSL_DEFAULT_COPTS}
LINKOPTS
${ABSL_DEFAULT_LINKOPTS}
- $<$<BOOL:${MINGW}>:"dbghelp">
+ $<$<BOOL:${MINGW}>:-ldbghelp>
DEPS
absl::debugging_internal
absl::demangle_internal
diff --git a/absl/random/CMakeLists.txt b/absl/random/CMakeLists.txt
index d04c7081..c74fd300 100644
--- a/absl/random/CMakeLists.txt
+++ b/absl/random/CMakeLists.txt
@@ -569,7 +569,7 @@ absl_cc_library(
${ABSL_DEFAULT_COPTS}
LINKOPTS
${ABSL_DEFAULT_LINKOPTS}
- $<$<BOOL:${MINGW}>:"bcrypt">
+ $<$<BOOL:${MINGW}>:-lbcrypt>
DEPS
absl::core_headers
absl::optional