summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2019-05-14 10:53:39 -0700
committerGravatar Andy Soffer <asoffer@google.com>2019-05-14 14:23:52 -0400
commit436ba6c4a0ea3a06eca6e055f9c8d296bf3bae12 (patch)
tree624a7ef0a545553ecce04123f0ccf463a9993477
parent0cbdc774b97f7e80ab60dbe2ed4eaca3b2e33fc8 (diff)
Export of internal Abseil changes.
-- 22fceefcf070a0cf89bf1846bee16a9d36ad4161 by Derek Mauro <dmauro@google.com>: Use function static for once initialization of flag registry. This is a workaround for the MSVC debug constexpr initialization issue in absl::once_flag. GitHub #304 PiperOrigin-RevId: 248169007 -- 97bbe6a5233802b61e758c55f7ba8926539cc4ca by Chris Kennelly <ckennelly@google.com>: Internal change PiperOrigin-RevId: 248139347 -- e72640ee079b9fa44e2c7f925fa0a608bcfea515 by Derek Mauro <dmauro@google.com>: Re-write flags config. It doesn't have to be written in the convoluted way it currently is in the opensource-only code path. PiperOrigin-RevId: 248010502 -- 2a72552511b8086c78cb43012c1644e519b3807e by Abseil Team <absl-team@google.com>: Handle pthread_getschedparam() failure. Log an error message if pthread_getschedparam() fails. In Android's Media Framework, libminijail (which I believe is a sandbox) aborts the process if pthread_getschedparam() is called: media.swcodec: libminijail[7526]: blocked syscall: sched_getparam ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ /system/bin/tombstoned: received crash request for pid 7526 Although this CL cannot handle that extreme failure mode, it handles an error return from pthread_getschedparam() and won't use the uninitialized param.sched_priority value in that case. PiperOrigin-RevId: 247999953 -- bb154a92be37987d00d652c7c792594f2f515d83 by Abseil Team <absl-team@google.com>: Allow intrinsic int128 to be set for __aarch64__ targets. PiperOrigin-RevId: 247977594 GitOrigin-RevId: 22fceefcf070a0cf89bf1846bee16a9d36ad4161 Change-Id: I1f7ccfd82eb71446277a8e6f542fe835ac173d71
-rw-r--r--absl/base/BUILD.bazel2
-rw-r--r--absl/base/config.h4
-rw-r--r--absl/flags/BUILD.bazel14
-rw-r--r--absl/flags/CMakeLists.txt12
-rw-r--r--absl/flags/config.h34
-rw-r--r--absl/flags/config_test.cc61
-rw-r--r--absl/flags/internal/registry.cc18
-rw-r--r--absl/synchronization/mutex.cc14
8 files changed, 114 insertions, 45 deletions
diff --git a/absl/base/BUILD.bazel b/absl/base/BUILD.bazel
index 317452da..c6f0e4d6 100644
--- a/absl/base/BUILD.bazel
+++ b/absl/base/BUILD.bazel
@@ -18,9 +18,9 @@ load(
"//absl:copts/configure_copts.bzl",
"ABSL_DEFAULT_COPTS",
"ABSL_DEFAULT_LINKOPTS",
- "ABSL_TEST_COPTS",
"ABSL_EXCEPTIONS_FLAG",
"ABSL_EXCEPTIONS_FLAG_LINKOPTS",
+ "ABSL_TEST_COPTS",
)
package(default_visibility = ["//visibility:public"])
diff --git a/absl/base/config.h b/absl/base/config.h
index 3b81e269..2a14fe74 100644
--- a/absl/base/config.h
+++ b/absl/base/config.h
@@ -191,15 +191,13 @@
// * On Clang:
// * Building using Clang for Windows, where the Clang runtime library has
// 128-bit support only on LP64 architectures, but Windows is LLP64.
-// * Building for aarch64, where __int128 exists but has exhibits a sporadic
-// compiler crashing bug.
// * On Nvidia's nvcc:
// * nvcc also defines __GNUC__ and __SIZEOF_INT128__, but not all versions
// actually support __int128.
#ifdef ABSL_HAVE_INTRINSIC_INT128
#error ABSL_HAVE_INTRINSIC_INT128 cannot be directly set
#elif defined(__SIZEOF_INT128__)
-#if (defined(__clang__) && !defined(_WIN32) && !defined(__aarch64__)) || \
+#if (defined(__clang__) && !defined(_WIN32)) || \
(defined(__CUDACC__) && __CUDACC_VER_MAJOR__ >= 9) || \
(defined(__GNUC__) && !defined(__clang__) && !defined(__CUDACC__))
#define ABSL_HAVE_INTRINSIC_INT128 1
diff --git a/absl/flags/BUILD.bazel b/absl/flags/BUILD.bazel
index 2d868b0a..bb1a7aac 100644
--- a/absl/flags/BUILD.bazel
+++ b/absl/flags/BUILD.bazel
@@ -220,6 +220,20 @@ cc_test(
)
cc_test(
+ name = "config_test",
+ size = "small",
+ srcs = [
+ "config_test.cc",
+ ],
+ copts = ABSL_TEST_COPTS,
+ linkopts = ABSL_DEFAULT_LINKOPTS,
+ deps = [
+ ":config",
+ "@com_google_googletest//:gtest_main",
+ ],
+)
+
+cc_test(
name = "flag_test",
size = "small",
srcs = [
diff --git a/absl/flags/CMakeLists.txt b/absl/flags/CMakeLists.txt
index 284d6279..9e0b441b 100644
--- a/absl/flags/CMakeLists.txt
+++ b/absl/flags/CMakeLists.txt
@@ -203,6 +203,18 @@ absl_cc_test(
absl_cc_test(
NAME
+ flags_config_test
+ SRCS
+ "config_test.cc"
+ COPTS
+ ${ABSL_TEST_COPTS}
+ DEPS
+ absl::flags_config
+ gtest_main
+)
+
+absl_cc_test(
+ NAME
flags_flag_test
SRCS
"flag_test.cc"
diff --git a/absl/flags/config.h b/absl/flags/config.h
index a734af46..a9fd97ad 100644
--- a/absl/flags/config.h
+++ b/absl/flags/config.h
@@ -17,38 +17,32 @@
#define ABSL_FLAGS_CONFIG_H_
// Determine if we should strip string literals from the Flag objects.
+// By default we strip string literals on mobile platforms.
#if !defined(ABSL_FLAGS_STRIP_NAMES)
-// Non-mobile linux platforms don't strip string literals.
-#if (defined(__linux__) || defined(__Fuchsia__)) && !defined(__ANDROID__)
-#define ABSL_FLAGS_STRIP_NAMES 0
+#if defined(__ANDROID__)
+#define ABSL_FLAGS_STRIP_NAMES 1
-// So do Macs (not iOS or embedded Apple platforms).
#elif defined(__APPLE__)
#include <TargetConditionals.h>
-#if !TARGET_OS_IPHONE && !TARGET_OS_EMBEDDED
-#define ABSL_FLAGS_STRIP_NAMES 0
+#if defined(TARGET_OS_IPHONE) && TARGET_OS_IPHONE
+#define ABSL_FLAGS_STRIP_NAMES 1
+#elif defined(TARGET_OS_EMBEDDED) && TARGET_OS_EMBEDDED
+#define ABSL_FLAGS_STRIP_NAMES 1
+#endif // TARGET_OS_*
#endif
-// And Windows.
-#elif defined(_WIN32)
-#define ABSL_FLAGS_STRIP_NAMES 0
+#endif // !defined(ABSL_FLAGS_STRIP_NAMES)
-// And Myriad.
-#elif defined(__myriad2__)
+#if !defined(ABSL_FLAGS_STRIP_NAMES)
+// If ABSL_FLAGS_STRIP_NAMES wasn't set on the command line or above,
+// the default is not to strip.
#define ABSL_FLAGS_STRIP_NAMES 0
-
#endif
-#endif // !defined(ABSL_FLAGS_STRIP_NAMES)
-#if ABSL_FLAGS_STRIP_NAMES
#if !defined(ABSL_FLAGS_STRIP_HELP)
-#define ABSL_FLAGS_STRIP_HELP 1
-#endif
-#else
-#if !defined(ABSL_FLAGS_STRIP_HELP)
-#define ABSL_FLAGS_STRIP_HELP 0
-#endif
+// By default, if we strip names, we also strip help.
+#define ABSL_FLAGS_STRIP_HELP ABSL_FLAGS_STRIP_NAMES
#endif
#endif // ABSL_FLAGS_CONFIG_H_
diff --git a/absl/flags/config_test.cc b/absl/flags/config_test.cc
new file mode 100644
index 00000000..63899866
--- /dev/null
+++ b/absl/flags/config_test.cc
@@ -0,0 +1,61 @@
+// Copyright 2019 The Abseil Authors.
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// https://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+#include "absl/flags/config.h"
+
+#ifdef __APPLE__
+#include <TargetConditionals.h>
+#endif
+
+#include "gtest/gtest.h"
+
+#ifndef ABSL_FLAGS_STRIP_NAMES
+#error ABSL_FLAGS_STRIP_NAMES is not defined
+#endif
+
+#ifndef ABSL_FLAGS_STRIP_HELP
+#error ABSL_FLAGS_STRIP_HELP is not defined
+#endif
+
+namespace {
+
+// Test that ABSL_FLAGS_STRIP_NAMES and ABSL_FLAGS_STRIP_HELP are configured how
+// we expect them to be configured by default. If you override this
+// configuration, this test will fail, but the code should still be safe to use.
+TEST(FlagsConfigTest, Test) {
+#if defined(__ANDROID__)
+ EXPECT_EQ(ABSL_FLAGS_STRIP_NAMES, 1);
+ EXPECT_EQ(ABSL_FLAGS_STRIP_HELP, 1);
+#elif defined(__myriad2__)
+ EXPECT_EQ(ABSL_FLAGS_STRIP_NAMES, 0);
+ EXPECT_EQ(ABSL_FLAGS_STRIP_HELP, 0);
+#elif defined(TARGET_OS_IPHONE) && TARGET_OS_IPHONE
+ EXPECT_EQ(ABSL_FLAGS_STRIP_NAMES, 1);
+ EXPECT_EQ(ABSL_FLAGS_STRIP_HELP, 1);
+#elif defined(TARGET_OS_EMBEDDED) && TARGET_OS_EMBEDDED
+ EXPECT_EQ(ABSL_FLAGS_STRIP_NAMES, 1);
+ EXPECT_EQ(ABSL_FLAGS_STRIP_HELP, 1);
+#elif defined(__APPLE__)
+ EXPECT_EQ(ABSL_FLAGS_STRIP_NAMES, 0);
+ EXPECT_EQ(ABSL_FLAGS_STRIP_HELP, 0);
+#elif defined(_WIN32)
+ EXPECT_EQ(ABSL_FLAGS_STRIP_NAMES, 0);
+ EXPECT_EQ(ABSL_FLAGS_STRIP_HELP, 0);
+#elif defined(__linux__)
+ EXPECT_EQ(ABSL_FLAGS_STRIP_NAMES, 0);
+ EXPECT_EQ(ABSL_FLAGS_STRIP_HELP, 0);
+#endif
+}
+
+} // namespace
diff --git a/absl/flags/internal/registry.cc b/absl/flags/internal/registry.cc
index 435c5b0b..e52cbb68 100644
--- a/absl/flags/internal/registry.cc
+++ b/absl/flags/internal/registry.cc
@@ -15,7 +15,6 @@
#include "absl/flags/internal/registry.h"
-#include "absl/base/call_once.h"
#include "absl/base/dynamic_annotations.h"
#include "absl/base/internal/raw_logging.h"
#include "absl/flags/config.h"
@@ -151,12 +150,6 @@ class FlagRegistry {
FlagPtrMap flag_ptr_map_;
- static FlagRegistry* global_registry_; // a singleton registry
-
- static absl::once_flag global_registry_once_;
-
- static void InitGlobalRegistry();
-
absl::Mutex lock_;
// Disallow
@@ -164,16 +157,9 @@ class FlagRegistry {
FlagRegistry& operator=(const FlagRegistry&);
};
-// Get the singleton FlagRegistry object
-FlagRegistry* FlagRegistry::global_registry_ = nullptr;
-absl::once_flag FlagRegistry::global_registry_once_;
-
-void FlagRegistry::InitGlobalRegistry() { global_registry_ = new FlagRegistry; }
-
FlagRegistry* FlagRegistry::GlobalRegistry() {
- absl::call_once(global_registry_once_, &InitGlobalRegistry);
-
- return global_registry_;
+ static FlagRegistry* global_registry = new FlagRegistry;
+ return global_registry;
}
namespace {
diff --git a/absl/synchronization/mutex.cc b/absl/synchronization/mutex.cc
index 3e8033a0..76bd307a 100644
--- a/absl/synchronization/mutex.cc
+++ b/absl/synchronization/mutex.cc
@@ -901,11 +901,15 @@ static PerThreadSynch *Enqueue(PerThreadSynch *head,
// base_internal::CycleClock::Now() is 0.5%.
int policy;
struct sched_param param;
- pthread_getschedparam(pthread_self(), &policy, &param);
- s->priority = param.sched_priority;
- s->next_priority_read_cycles =
- now_cycles +
- static_cast<int64_t>(base_internal::CycleClock::Frequency());
+ const int err = pthread_getschedparam(pthread_self(), &policy, &param);
+ if (err != 0) {
+ ABSL_RAW_LOG(ERROR, "pthread_getschedparam failed: %d", err);
+ } else {
+ s->priority = param.sched_priority;
+ s->next_priority_read_cycles =
+ now_cycles +
+ static_cast<int64_t>(base_internal::CycleClock::Frequency());
+ }
}
if (s->priority > head->priority) { // s's priority is above head's
// try to put s in priority-fifo order, or failing that at the front.