summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Mark Barolak <mbxx@users.noreply.github.com>2018-12-20 15:36:51 -0500
committerGravatar GitHub <noreply@github.com>2018-12-20 15:36:51 -0500
commit3e2e9b5557e76d098de4b8a2a659125b98ca519b (patch)
tree5d023dbd4de688eccb15a7487fefbfc8046eda1e
parent111ca7060a6ff50115ca85b59f6b5d8c8c5e9105 (diff)
parente41b5b1c8a9b20e89bde00fe388e8c7b74cfa229 (diff)
Merge pull request #231 from uilianries/feature/conan
#187 Add Conan recipe
-rw-r--r--conanfile.py83
1 files changed, 83 insertions, 0 deletions
diff --git a/conanfile.py b/conanfile.py
new file mode 100644
index 00000000..d8307b45
--- /dev/null
+++ b/conanfile.py
@@ -0,0 +1,83 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+# Note: Conan is supported on a best-effort basis. Abseil doesn't use Conan
+# internally, so we won't know if it stops working. We may ask community
+# members to help us debug any problems that arise.
+
+from conans import ConanFile, CMake, tools
+from conans.errors import ConanInvalidConfiguration
+from conans.model.version import Version
+
+
+class AbseilConan(ConanFile):
+ name = "abseil"
+ url = "https://github.com/abseil/abseil-cpp"
+ homepage = url
+ author = "Abseil <abseil-io@googlegroups.com>"
+ description = "Abseil Common Libraries (C++) from Google"
+ license = "Apache-2.0"
+ topics = ("conan", "abseil", "abseil-cpp", "google", "common-libraries")
+ exports = ["LICENSE"]
+ exports_sources = ["CMakeLists.txt", "CMake/*", "absl/*"]
+ generators = "cmake"
+ settings = "os", "arch", "compiler", "build_type"
+
+ def configure(self):
+ if self.settings.os == "Windows" and \
+ self.settings.compiler == "Visual Studio" and \
+ Version(self.settings.compiler.version.value) < "14":
+ raise ConanInvalidConfiguration("Abseil does not support MSVC < 14")
+
+ def build(self):
+ tools.replace_in_file("CMakeLists.txt", "project(absl)", "project(absl)\ninclude(conanbuildinfo.cmake)\nconan_basic_setup()")
+ cmake = CMake(self)
+ cmake.definitions["BUILD_TESTING"] = False
+ cmake.configure()
+ cmake.build()
+
+ def package(self):
+ self.copy("LICENSE", dst="licenses")
+ self.copy("*.h", dst="include", src="absl")
+ self.copy("*.inc", dst="include", src="absl")
+ self.copy("*.a", dst="lib", src=".", keep_path=False)
+ self.copy("*.lib", dst="lib", src=".", keep_path=False)
+
+ def package_info(self):
+ self.cpp_info.libs = ["absl_base",
+ "absl_synchronization",
+ "absl_strings",
+ "absl_symbolize",
+ "absl_malloc_internal",
+ "absl_time",
+ "absl_strings",
+ "absl_base",
+ "absl_dynamic_annotations",
+ "absl_spinlock_wait",
+ "absl_throw_delegate",
+ "absl_stacktrace",
+ "absl_int128",
+ "absl_span",
+ "test_instance_tracker_lib",
+ "absl_stack_consumption",
+ "absl_bad_any_cast",
+ "absl_hash",
+ "str_format_extension_internal",
+ "absl_failure_signal_handler",
+ "absl_str_format",
+ "absl_numeric",
+ "absl_any",
+ "absl_optional",
+ "absl_container",
+ "absl_debugging",
+ "absl_memory",
+ "absl_leak_check",
+ "absl_meta",
+ "absl_utility",
+ "str_format_internal",
+ "absl_variant",
+ "absl_examine_stack",
+ "absl_bad_optional_access",
+ "absl_algorithm"]
+ if self.settings.os == "Linux":
+ self.cpp_info.libs.append("pthread")