summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2019-07-18 09:04:43 -0700
committerGravatar Derek Mauro <dmauro@google.com>2019-07-18 13:19:32 -0400
commit278b26058c036833a4f7f3047d3f4d9296527f87 (patch)
treef7d3721cf61782b74c715d42a34495babd32eb67
parentc6c3c1b498e4ee939b24be59cae29d59c3863be8 (diff)
Export of internal Abseil changes.
-- b0015627610a311997ab21b8b295a8168b5915ec by Derek Mauro <dmauro@google.com>: Add an empty log_severity library. The log_severity sources will eventually migrate here once users are updated to depend on the new target. Note that no opensource user should be depending on log_severity.h today since it has no purpose in opensource. PiperOrigin-RevId: 258781702 -- c4d8d03f731d1de648ef2d17a55c3a16029ba331 by Derek Mauro <dmauro@google.com>: Move atomic_hook.h to its own internal target. PiperOrigin-RevId: 258765527 GitOrigin-RevId: b0015627610a311997ab21b8b295a8168b5915ec Change-Id: I0ec9b8b3cb6a27dc32a5f6c318d07e02548f193d
-rw-r--r--absl/base/BUILD.bazel22
-rw-r--r--absl/base/CMakeLists.txt20
-rw-r--r--absl/synchronization/BUILD.bazel1
-rw-r--r--absl/synchronization/CMakeLists.txt1
4 files changed, 40 insertions, 4 deletions
diff --git a/absl/base/BUILD.bazel b/absl/base/BUILD.bazel
index 5b7b295a..1cdd1909 100644
--- a/absl/base/BUILD.bazel
+++ b/absl/base/BUILD.bazel
@@ -28,6 +28,22 @@ package(default_visibility = ["//visibility:public"])
licenses(["notice"]) # Apache 2.0
cc_library(
+ name = "atomic_hook",
+ hdrs = ["internal/atomic_hook.h"],
+ copts = ABSL_DEFAULT_COPTS,
+ linkopts = ABSL_DEFAULT_LINKOPTS,
+ visibility = [
+ "//absl:__subpackages__",
+ ],
+)
+
+cc_library(
+ name = "log_severity",
+ copts = ABSL_DEFAULT_COPTS,
+ linkopts = ABSL_DEFAULT_LINKOPTS,
+)
+
+cc_library(
name = "spinlock_wait",
srcs = [
"internal/spinlock_akaros.inc",
@@ -143,7 +159,6 @@ cc_library(
hdrs = [
"call_once.h",
"casts.h",
- "internal/atomic_hook.h",
"internal/cycleclock.h",
"internal/low_level_scheduling.h",
"internal/per_thread_tls.h",
@@ -161,10 +176,12 @@ cc_library(
"//conditions:default": ["-pthread"],
}) + ABSL_DEFAULT_LINKOPTS,
deps = [
+ ":atomic_hook",
":base_internal",
":config",
":core_headers",
":dynamic_annotations",
+ ":log_severity",
":spinlock_wait",
"//absl/meta:type_traits",
],
@@ -177,7 +194,7 @@ cc_test(
copts = ABSL_TEST_COPTS,
linkopts = ABSL_DEFAULT_LINKOPTS,
deps = [
- ":base",
+ ":atomic_hook",
":core_headers",
"@com_google_googletest//:gtest_main",
],
@@ -536,6 +553,7 @@ cc_test(
linkopts = ABSL_DEFAULT_LINKOPTS,
deps = [
":base",
+ ":log_severity",
"@com_google_googletest//:gtest_main",
],
)
diff --git a/absl/base/CMakeLists.txt b/absl/base/CMakeLists.txt
index 34bfba27..f27e121e 100644
--- a/absl/base/CMakeLists.txt
+++ b/absl/base/CMakeLists.txt
@@ -16,6 +16,22 @@
absl_cc_library(
NAME
+ atomic_hook
+ HDRS
+ "internal/atomic_hook.h"
+ COPTS
+ ${ABSL_DEFAULT_COPTS}
+)
+
+absl_cc_library(
+ NAME
+ log_severity
+ COPTS
+ ${ABSL_DEFAULT_COPTS}
+)
+
+absl_cc_library(
+ NAME
spinlock_wait
HDRS
"internal/scheduling_mode.h"
@@ -112,7 +128,6 @@ absl_cc_library(
HDRS
"call_once.h"
"casts.h"
- "internal/atomic_hook.h"
"internal/cycleclock.h"
"internal/low_level_scheduling.h"
"internal/per_thread_tls.h"
@@ -134,6 +149,7 @@ absl_cc_library(
COPTS
${ABSL_DEFAULT_COPTS}
DEPS
+ absl::atomic_hook
absl::base_internal
absl::config
absl::core_headers
@@ -227,7 +243,7 @@ absl_cc_test(
COPTS
${ABSL_TEST_COPTS}
DEPS
- absl::base
+ absl::atomic_hook
absl::core_headers
gtest_main
)
diff --git a/absl/synchronization/BUILD.bazel b/absl/synchronization/BUILD.bazel
index 67da9d46..fca8cb69 100644
--- a/absl/synchronization/BUILD.bazel
+++ b/absl/synchronization/BUILD.bazel
@@ -78,6 +78,7 @@ cc_library(
deps = [
":graphcycles_internal",
"//absl/base",
+ "//absl/base:atomic_hook",
"//absl/base:base_internal",
"//absl/base:config",
"//absl/base:core_headers",
diff --git a/absl/synchronization/CMakeLists.txt b/absl/synchronization/CMakeLists.txt
index 6fdbcb28..4b708823 100644
--- a/absl/synchronization/CMakeLists.txt
+++ b/absl/synchronization/CMakeLists.txt
@@ -55,6 +55,7 @@ absl_cc_library(
${ABSL_DEFAULT_COPTS}
DEPS
absl::graphcycles_internal
+ absl::atomic_hook
absl::base
absl::base_internal
absl::config