summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Derek Mauro <761129+derekmauro@users.noreply.github.com>2022-06-23 14:22:47 -0400
committerGravatar GitHub <noreply@github.com>2022-06-23 14:22:47 -0400
commit273292d1cfc0a94a65082ee350509af1d113344d (patch)
tree7e5ede61413177fa9a43102b625b0a0f64e50b60
parent4dc63bade3ef2c099f328f2e08f6d4bf6658f0cf (diff)
Apply LTS transformations for 20220623 LTS branch (#1202)20220623.rc120220623.0
-rw-r--r--CMake/AbseilHelpers.cmake2
-rw-r--r--CMakeLists.txt14
-rw-r--r--WORKSPACE8
-rw-r--r--absl/base/config.h4
-rw-r--r--absl/base/options.h4
-rw-r--r--ci/cmake_common.sh2
6 files changed, 12 insertions, 22 deletions
diff --git a/CMake/AbseilHelpers.cmake b/CMake/AbseilHelpers.cmake
index 6d03381b..dbb09fe2 100644
--- a/CMake/AbseilHelpers.cmake
+++ b/CMake/AbseilHelpers.cmake
@@ -281,7 +281,7 @@ Cflags: -I\${includedir}${PC_CFLAGS}\n")
if(ABSL_ENABLE_INSTALL)
set_target_properties(${_NAME} PROPERTIES
OUTPUT_NAME "absl_${_NAME}"
- SOVERSION 0
+ SOVERSION "2206.0.0"
)
endif()
else()
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a20d04a..79869ff5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,7 +46,7 @@ if (POLICY CMP0091)
cmake_policy(SET CMP0091 NEW)
endif (POLICY CMP0091)
-project(absl LANGUAGES CXX)
+project(absl LANGUAGES CXX VERSION 20220623)
include(CTest)
# Output directory is correct by default for most build setups. However, when
@@ -172,17 +172,7 @@ endif()
add_subdirectory(absl)
if(ABSL_ENABLE_INSTALL)
- # absl:lts-remove-begin(system installation is supported for LTS releases)
- # We don't support system-wide installation
- list(APPEND SYSTEM_INSTALL_DIRS "/usr/local" "/usr" "/opt/" "/opt/local" "c:/Program Files/${PROJECT_NAME}")
- if(NOT DEFINED CMAKE_INSTALL_PREFIX OR CMAKE_INSTALL_PREFIX IN_LIST SYSTEM_INSTALL_DIRS)
- message(WARNING "\
- The default and system-level install directories are unsupported except in LTS \
- releases of Abseil. Please set CMAKE_INSTALL_PREFIX to install Abseil in your \
- source or build tree directly.\
- ")
- endif()
- # absl:lts-remove-end
+
# install as a subdirectory only
install(EXPORT ${PROJECT_NAME}Targets
diff --git a/WORKSPACE b/WORKSPACE
index 072fa93d..c332ba4e 100644
--- a/WORKSPACE
+++ b/WORKSPACE
@@ -20,11 +20,11 @@ load("@bazel_tools//tools/build_defs/repo:http.bzl", "http_archive")
# GoogleTest/GoogleMock framework. Used by most unit-tests.
http_archive(
- name = "com_google_googletest", # 2022-06-16T20:18:32Z
- sha256 = "a1d3123179024258f9c399d45da3e0b09c4aaf8d2c041466ce5b4793a8929f23",
- strip_prefix = "googletest-86add13493e5c881d7e4ba77fb91c1f57752b3a4",
+ name = "com_google_googletest",
+ sha256 = "ce7366fe57eb49928311189cb0e40e0a8bf3d3682fca89af30d884c25e983786",
+ strip_prefix = "googletest-release-1.12.0",
# Keep this URL in sync with ABSL_GOOGLETEST_COMMIT in ci/cmake_common.sh.
- urls = ["https://github.com/google/googletest/archive/86add13493e5c881d7e4ba77fb91c1f57752b3a4.zip"],
+ urls = ["https://github.com/google/googletest/archive/refs/tags/release-1.12.0.zip"],
)
# RE2 (the regular expression library used by GoogleTest)
diff --git a/absl/base/config.h b/absl/base/config.h
index 94f7fcb5..8533aead 100644
--- a/absl/base/config.h
+++ b/absl/base/config.h
@@ -111,8 +111,8 @@
//
// LTS releases can be obtained from
// https://github.com/abseil/abseil-cpp/releases.
-#undef ABSL_LTS_RELEASE_VERSION
-#undef ABSL_LTS_RELEASE_PATCH_LEVEL
+#define ABSL_LTS_RELEASE_VERSION 20220623
+#define ABSL_LTS_RELEASE_PATCH_LEVEL 0
// Helper macro to convert a CPP variable to a string literal.
#define ABSL_INTERNAL_DO_TOKEN_STR(x) #x
diff --git a/absl/base/options.h b/absl/base/options.h
index 230bf1ee..bc598470 100644
--- a/absl/base/options.h
+++ b/absl/base/options.h
@@ -205,8 +205,8 @@
// be changed to a new, unique identifier name. In particular "head" is not
// allowed.
-#define ABSL_OPTION_USE_INLINE_NAMESPACE 0
-#define ABSL_OPTION_INLINE_NAMESPACE_NAME head
+#define ABSL_OPTION_USE_INLINE_NAMESPACE 1
+#define ABSL_OPTION_INLINE_NAMESPACE_NAME lts_20220623
// ABSL_OPTION_HARDENED
//
diff --git a/ci/cmake_common.sh b/ci/cmake_common.sh
index 372038a5..3c08255b 100644
--- a/ci/cmake_common.sh
+++ b/ci/cmake_common.sh
@@ -14,7 +14,7 @@
# The commit of GoogleTest to be used in the CMake tests in this directory.
# Keep this in sync with the commit in the WORKSPACE file.
-readonly ABSL_GOOGLETEST_COMMIT="86add13493e5c881d7e4ba77fb91c1f57752b3a4"
+readonly ABSL_GOOGLETEST_COMMIT="15460959cbbfa20e66ef0b5ab497367e47fc0a04" # release-1.12.0
# Avoid depending on GitHub by looking for a cached copy of the commit first.
if [[ -r "${KOKORO_GFILE_DIR:-}/distdir/${ABSL_GOOGLETEST_COMMIT}.zip" ]]; then