summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Derek Mauro <dmauro@google.com>2022-09-02 10:32:30 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2022-09-02 10:33:04 -0700
commit152e9a182675cea81ba38ae6784c9980132b0bdc (patch)
tree3f4351353aff1d718524fa538270665882be137d
parentb922dbefc4637d49fdde6305c3d991343041e66e (diff)
CMake: Mark hash_testing as a public testonly library, as it is with Bazel
PiperOrigin-RevId: 471833563 Change-Id: Ida281308afab67e73b2da61418e82b22c2110ef9
-rw-r--r--absl/hash/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/absl/hash/CMakeLists.txt b/absl/hash/CMakeLists.txt
index 423b74b5..46365790 100644
--- a/absl/hash/CMakeLists.txt
+++ b/absl/hash/CMakeLists.txt
@@ -24,7 +24,7 @@ absl_cc_library(
"internal/hash.h"
COPTS
${ABSL_DEFAULT_COPTS}
- DEPS
+ DEPS
absl::city
absl::config
absl::core_headers
@@ -55,6 +55,7 @@ absl_cc_library(
absl::variant
GTest::gmock
TESTONLY
+ PUBLIC
)
absl_cc_test(