summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..8cd0cac
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,28 @@
+{ pkgs ? (import <nixpkgs> {}), coq-version-or-url, shell ? false }:
+
+let
+ coq-version-parts = builtins.match "([0-9]+).([0-9]+)" coq-version-or-url;
+ coqPackages =
+ if coq-version-parts == null then
+ pkgs.mkCoqPackages (import (fetchTarball coq-version-or-url) {})
+ else
+ pkgs."coqPackages_${builtins.concatStringsSep "_" coq-version-parts}";
+in
+
+with coqPackages;
+
+pkgs.stdenv.mkDerivation {
+
+ name = "aac-tactics";
+
+ buildInputs = with coq.ocamlPackages; [ ocaml findlib camlp5 ]
+ ++ pkgs.lib.optionals shell [ merlin ocp-indent ocp-index ];
+
+ propagatedBuildInputs = [
+ coq
+ ];
+
+ src = if shell then null else ./.;
+
+ installFlags = "COQLIB=$(out)/lib/coq/${coq.coq-version}/";
+}