summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 5 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index da4c4c4..792a1d2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,22 +6,18 @@ include /usr/share/coq/coqvars.mk
%:
dh $@ --with ocaml
-.PHONY: override_dh_auto_configure
-override_dh_auto_configure:
- ./make_makefile
-
.PHONY: override_dh_auto_build
override_dh_auto_build:
$(MAKE) world
.PHONY: override_dh_auto_install
override_dh_auto_install:
-# install rule as generated by coq_makefile is buggy
+ $(MAKE) -f Makefile.coq install DSTROOT=$(CURDIR)/debian/tmp
+
+.PHONY: override_dh_install
+override_dh_install:
+ dh_install --fail-missing
.PHONY: override_dh_gencontrol
override_dh_gencontrol:
dh_gencontrol -- -VF:CoqABI="$(COQ_ABI)"
-
-.PHONY: override_dh_auto_clean
-override_dh_auto_clean:
- rm -Rf .depend *.glob *.d *.*o *.*a *.cm* doc html