summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index abf2ec6..3e77020 100644
--- a/Makefile
+++ b/Makefile
@@ -1,16 +1,16 @@
all: Makefile.coq
- +make -f Makefile.coq all
+ +$(MAKE) -f Makefile.coq all
clean: Makefile.coq
- +make -f Makefile.coq clean
- rm -f Makefile.coq
+ +$(MAKE) -f Makefile.coq cleanall
+ rm -f Makefile.coq Makefile.coq.conf
-Makefile.coq: Make
- $(COQBIN)coq_makefile -f Make -o Makefile.coq
+Makefile.coq: _CoqProject
+ $(COQBIN)coq_makefile -f _CoqProject -o Makefile.coq
-Make: ;
+_CoqProject Makefile: ;
%: Makefile.coq
- +make -f Makefile.coq $@
+ +$(MAKE) -f Makefile.coq $@
.PHONY: all clean