summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2010-11-29 23:44:17 +0100
committerGravatar Stephane Glondu <steph@glondu.net>2010-11-30 13:59:56 +0100
commitcb529a5fc2c760f57db3f2213570044442540992 (patch)
tree2480442b91443fd71b97af6531fc579749d43d3e /debian/rules
parent1aa8b6f6a876af22f538c869f022bc4ca5986b40 (diff)
Initial packaging
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..446d604
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+include /usr/share/coq/coqvars.mk
+
+%:
+ dh $@ --with ocaml
+
+.PHONY: override_dh_auto_configure
+override_dh_auto_configure:
+ ./make_makefile
+# workaround bug on fs mounted without relatime
+ touch make_makefile theory.ml
+
+.PHONY: override_dh_auto_build
+override_dh_auto_build:
+ $(MAKE) world
+
+.PHONY: override_dh_gencontrol
+override_dh_gencontrol:
+ dh_gencontrol -- -VF:CoqABI="$(COQ_ABI)"
+
+.PHONY: override_dh_auto_clean
+override_dh_auto_clean:
+ rm -Rf Makefile .depend *.glob *.d *.*o *.*a *.cm* doc html