aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/citra/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/citra/CMakeLists.txt')
-rw-r--r--src/citra/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/citra/CMakeLists.txt b/src/citra/CMakeLists.txt
index 147f51e9..1ad607d7 100644
--- a/src/citra/CMakeLists.txt
+++ b/src/citra/CMakeLists.txt
@@ -1,12 +1,19 @@
set(SRCS citra.cpp
emu_window/emu_window_glfw.cpp)
+set(HEADERS citra.h
+ resource.h)
# NOTE: This is a workaround for CMake bug 0006976 (missing X11_xf86vmode_LIB variable)
if (NOT X11_xf86vmode_LIB)
set(X11_xv86vmode_LIB Xxf86vm)
endif()
-add_executable(citra ${SRCS})
-target_link_libraries(citra core common video_core GLEW pthread X11 Xxf86vm Xi Xcursor ${OPENGL_LIBRARIES} ${GLFW_LIBRARIES} rt ${X11_Xrandr_LIB} ${X11_xv86vmode_LIB})
+add_executable(citra ${SRCS} ${HEADERS})
+
+if (APPLE)
+ target_link_libraries(citra core common video_core iconv pthread ${COREFOUNDATION_LIBRARY} ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLFW_LIBRARIES})
+else()
+ target_link_libraries(citra core common video_core GLEW pthread X11 Xxf86vm Xi Xcursor ${OPENGL_LIBRARIES} ${GLFW_LIBRARIES} rt ${X11_Xrandr_LIB} ${X11_xv86vmode_LIB})
+endif()
#install(TARGETS citra RUNTIME DESTINATION ${bindir})