aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0adc5e6f..6f886b21 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,15 +9,9 @@ add_definitions(-DSINGLETHREADED)
# dependency checking
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/CMakeTests)
include(FindOpenGL REQUIRED)
-include(FindGLFW REQUIRED)
include(FindX11 REQUIRED)
-if(NOT GLFW_FOUND)
- message(FATAL_ERROR "glfw not found")
-else()
- include_directories(${GLFW_INCLUDE_DIRS})
-endif()
-
+include_directories(${GLFW_INCLUDE_DIRS})
option(DISABLE_QT4 "Disable Qt4 GUI" OFF)
if(NOT DISABLE_QT4)
include(FindQt4)
@@ -33,7 +27,6 @@ if(NOT DISABLE_QT4)
endif()
# external includes
-include_directories(${SDL2_INCLUDE_DIR})
include_directories(${OPENGL_INCLUDE_DIR})
# internal includes