aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2015-05-12 22:38:29 -0300
committerGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2015-05-15 00:04:38 -0300
commit7ada357b2d12cf616672425a8961804b865354d6 (patch)
tree983003c1efc0950605eca3aa7d135b7c8fe9edcf /src/core/CMakeLists.txt
parenta251721bf3a053ea012ac0b891826f3246273c82 (diff)
Memmap: Re-organize memory function in two files
memory.cpp/h contains definitions related to acessing memory and configuring the address space mem_map.cpp/h contains higher-level definitions related to configuring the address space accoording to the kernel and allocating memory.
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index ebedcb71..3b67cc49 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -99,7 +99,7 @@ set(SRCS
loader/loader.cpp
loader/ncch.cpp
mem_map.cpp
- mem_map_funcs.cpp
+ memory.cpp
settings.cpp
system.cpp
)
@@ -211,6 +211,7 @@ set(HEADERS
loader/loader.h
loader/ncch.h
mem_map.h
+ memory.h
settings.h
system.h
)