aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar ShizZy <shizzy@6bit.net>2014-04-22 18:35:40 -0400
committerGravatar ShizZy <shizzy@6bit.net>2014-04-22 18:35:40 -0400
commit5c89324809f3753e143638acee1168d98ff7db6c (patch)
treedb2df30e5ad3e627e07d1802a0b6156ba1b1948c /src/core/CMakeLists.txt
parent81f6062c85290dd2e63d0083e9f1c32a77d7783e (diff)
updated CMakeLists for missing files
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 9cfb9b1c..3ba3afa7 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -17,7 +17,15 @@ set(SRCS core.cpp
elf/elf_reader.cpp
file_sys/directory_file_system.cpp
file_sys/meta_file_system.cpp
+ hle/hle.cpp
+ hle/syscall.cpp
+ hle/service/apt.cpp
+ hle/service/gsp.cpp
+ hle/service/hid.cpp
+ hle/service/service.cpp
+ hle/service/srv.cpp
hw/hw.cpp
- hw/hw_lcd.cpp)
+ hw/lcd.cpp
+ hw/ndma.cpp)
add_library(core STATIC ${SRCS})