aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar bunnei <ericbunnie@gmail.com>2014-05-15 22:54:17 -0400
committerGravatar bunnei <ericbunnie@gmail.com>2014-05-15 22:54:17 -0400
commit3e1eafa244dc2ea6a1d8de6e841370c83c362dda (patch)
treef4fb8778ccb4d71cc73c10a7ad4d0be62acc4533 /src/core/CMakeLists.txt
parentbdc54d0d4897841a4d24aee80311bfb1f0eba884 (diff)
- moved mmu to arm/interpreter folder
- added initial VFP code from skyeye
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index eb4fef38..0d4a0ca7 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -14,7 +14,11 @@ set(SRCS core.cpp
arm/interpreter/armsupp.cpp
arm/interpreter/armvirt.cpp
arm/interpreter/thumbemu.cpp
- arm/mmu/arm1176jzf_s_mmu.cpp
+ arm/interpreter/vfp/vfp.cpp
+ arm/interpreter/vfp/vfpdouble.cpp
+ arm/interpreter/vfp/vfpinsr.cpp
+ arm/interpreter/vfp/vfpsingle.cpp
+ arm/interpreter/mmu/arm1176jzf_s_mmu.cpp
elf/elf_reader.cpp
file_sys/directory_file_system.cpp
file_sys/meta_file_system.cpp