aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Subv <subv2112@gmail.com>2014-12-29 13:04:37 -0500
committerGravatar Subv <subv2112@gmail.com>2014-12-29 22:29:55 -0500
commit2c89d4d5cd4e308b04cebb1c9bca48e12f0945da (patch)
treeea0a85e43943ba76418f27a68572e8602dbd9839 /src/core/CMakeLists.txt
parent3d14eb285382740b144e5b047cb2ad072f6129ea (diff)
Archives: Implemented ExtSaveData and SharedExtSaveData
They will be stored in /extsavedata/SDMC and /extsavedata/NAND respectively. Also redirect some APT_A functions to their APT_U equivalents. Implemented the gamecoin.dat file in SharedExtSaveData in the PTM module. Implemented formatting the savegame. Retake a previous savegame if it exists instead of reporting them as not formatted every time a game is loaded.
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index fdd97c18..89ea70d2 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -17,6 +17,7 @@ set(SRCS
arm/skyeye_common/vfp/vfpdouble.cpp
arm/skyeye_common/vfp/vfpinstr.cpp
arm/skyeye_common/vfp/vfpsingle.cpp
+ file_sys/archive_extsavedata.cpp
file_sys/archive_romfs.cpp
file_sys/archive_savedata.cpp
file_sys/archive_sdmc.cpp
@@ -104,6 +105,7 @@ set(HEADERS
arm/skyeye_common/vfp/vfp_helper.h
arm/arm_interface.h
file_sys/archive_backend.h
+ file_sys/archive_extsavedata.h
file_sys/archive_romfs.h
file_sys/archive_savedata.h
file_sys/archive_sdmc.h