aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar bunnei <ericbunnie@gmail.com>2014-06-27 16:18:56 -0400
committerGravatar bunnei <bunneidev@gmail.com>2014-07-04 20:37:45 -0400
commit17a6148f9df406a6ca4bdca98777e0aaf21f582a (patch)
tree3763cf9417649428c81c7e9e0cb6abac251faa49 /src/core/CMakeLists.txt
parent82702fedb831c98479be7c4ea2caae920302efa6 (diff)
FileSys: Added preliminary support for applications reading the RomFS archive.
Archive: Fixed brace ugliness for neobrain :) FS: Commented out unused local variables to prevent warnings. ...But keeping them here for future use. archive_romfs: Removed unused #include.
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 978e956d..9ee803fd 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -8,6 +8,7 @@ set(SRCS core.cpp
system.cpp
arm/disassembler/arm_disasm.cpp
arm/disassembler/load_symbol_map.cpp
+ file_sys/archive_romfs.cpp
arm/interpreter/arm_interpreter.cpp
arm/interpreter/armcopro.cpp
arm/interpreter/armemu.cpp
@@ -75,7 +76,8 @@ set(HEADERS core.h
arm/interpreter/vfp/asm_vfp.h
arm/interpreter/vfp/vfp.h
arm/interpreter/vfp/vfp_helper.h
- file_sys/file_sys.h
+ file_sys/archive.h
+ file_sys/archive_romfs.h
hle/config_mem.h
hle/coprocessor.h
hle/hle.h