aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/citrus/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar ShizZy <shizzy@6bit.net>2013-09-13 18:11:14 -0400
committerGravatar ShizZy <shizzy@6bit.net>2013-09-13 18:11:14 -0400
commitb8ca09160b39120d1f55a2016cb652810dbd5619 (patch)
treec831cd66f94e45421f755986e2ffe8b64323d976 /src/citrus/CMakeLists.txt
parent9709dd2def24260ec2ea4fdc16e3a78fa206bbb9 (diff)
renamed project to 'citrus'
Diffstat (limited to 'src/citrus/CMakeLists.txt')
-rw-r--r--src/citrus/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/citrus/CMakeLists.txt b/src/citrus/CMakeLists.txt
new file mode 100644
index 00000000..6858a589
--- /dev/null
+++ b/src/citrus/CMakeLists.txt
@@ -0,0 +1,12 @@
+set(SRCS src/citrus.cpp
+ src/emuwindow/emuwindow_glfw.cpp)
+
+# NOTE: This is a workaround for CMake bug 0006976 (missing X11_xf86vmode_LIB variable)
+if (NOT X11_xf86vmode_LIB)
+ set(X11_xv86vmode_LIB Xxf86vm)
+endif()
+
+add_executable(citrus ${SRCS})
+target_link_libraries(citrus core common ${OPENGL_LIBRARIES} ${GLFW_LIBRARIES} GLEW rt ${X11_Xrandr_LIB} ${X11_xv86vmode_LIB})
+
+#install(TARGETS citrus RUNTIME DESTINATION ${bindir})