aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/citra_qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tony Wasserka <NeoBrainX@gmail.com>2014-11-01 15:36:59 +0100
committerGravatar Tony Wasserka <NeoBrainX@gmail.com>2014-12-09 16:37:34 +0100
commitbf6b23f4a0ea01af2c5e87b0fcabd1aea4a51fd6 (patch)
tree78b5c480201e8b6b586949b8382153b312fc6e95 /src/citra_qt/CMakeLists.txt
parent8db65723d233486ac98ab9112a81f80b0313c7f7 (diff)
citra-qt: Add a utility spinbox class called CSpinBox.
This class has a few advantages over the regular QSpinBox: - QSpinBox stores its as signed 32 bit integers, which for instance is unsuitable for representing memory addresses. CSpinBox uses 64 bit integers instead. - QSpinBox does not provide an easy way to handle number input from bases different than 10. - QSpinBox is quite inflexible in general and almost any sort of customization requires reimplementing it anyway.
Diffstat (limited to 'src/citra_qt/CMakeLists.txt')
-rw-r--r--src/citra_qt/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/citra_qt/CMakeLists.txt b/src/citra_qt/CMakeLists.txt
index 98a48a69..7bf44197 100644
--- a/src/citra_qt/CMakeLists.txt
+++ b/src/citra_qt/CMakeLists.txt
@@ -11,6 +11,7 @@ set(SRCS
debugger/graphics_cmdlists.cpp
debugger/ramview.cpp
debugger/registers.cpp
+ util/spinbox.cpp
bootmanager.cpp
hotkeys.cpp
main.cpp
@@ -26,6 +27,7 @@ set(HEADERS
debugger/graphics_cmdlists.hxx
debugger/ramview.hxx
debugger/registers.hxx
+ util/spinbox.hxx
bootmanager.hxx
hotkeys.hxx
main.hxx