aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/citra_qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Sacha <xsacha@gmail.com>2014-08-18 14:35:44 +1000
committerGravatar Sacha <xsacha@gmail.com>2014-08-18 14:35:44 +1000
commitb7ecc9543ad0ee9d5d083fe1ca7018f876b2ae10 (patch)
treeeb357a371e850a735efd1ea5f25de92b4e67d0e0 /src/citra_qt/CMakeLists.txt
parent68c81f28d947193d050cb04bbcfd42b6ef1307f3 (diff)
CMake Cleanup
Diffstat (limited to 'src/citra_qt/CMakeLists.txt')
-rw-r--r--src/citra_qt/CMakeLists.txt32
1 files changed, 9 insertions, 23 deletions
diff --git a/src/citra_qt/CMakeLists.txt b/src/citra_qt/CMakeLists.txt
index 7f880df8..5ce4e3f1 100644
--- a/src/citra_qt/CMakeLists.txt
+++ b/src/citra_qt/CMakeLists.txt
@@ -1,3 +1,6 @@
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
set(SRCS
bootmanager.cpp
debugger/callstack.cpp
@@ -10,6 +13,7 @@ set(SRCS
main.cpp
config/controller_config.cpp
config/controller_config_util.cpp)
+
set (HEADERS
bootmanager.hxx
debugger/callstack.hxx
@@ -18,12 +22,6 @@ set (HEADERS
debugger/registers.hxx
hotkeys.hxx
main.hxx
- ui_callstack.h
- ui_controller_config.h
- ui_disassembler.h
- ui_hotkeys.h
- ui_main.h
- ui_registers.h
version.h
config/controller_config.hxx
config/controller_config_util.hxx)
@@ -36,28 +34,16 @@ qt4_wrap_ui(UI_HDRS
main.ui
config/controller_config.ui)
-qt4_wrap_cpp(MOC_SRCS
- bootmanager.hxx
- debugger/callstack.hxx
- debugger/disassembler.hxx
- debugger/graphics.hxx
- debugger/graphics_cmdlists.hxx
- debugger/registers.hxx
- debugger/ramview.hxx
- hotkeys.hxx
- main.hxx
- config/controller_config.hxx
- config/controller_config_util.hxx)
-
# add uic results to include directories
include_directories(${CMAKE_CURRENT_BINARY_DIR})
-include_directories(./)
-add_executable(citra-qt ${SRCS} ${HEADERS} ${MOC_SRCS} ${UI_HDRS})
+add_executable(citra-qt ${SRCS} ${UI_HDRS})
if (APPLE)
- target_link_libraries(citra-qt core common video_core qhexedit iconv ${COREFOUNDATION_LIBRARY} ${QT_LIBRARIES} ${GLEW_LIBRARY} ${OPENGL_LIBRARIES})
+ set(ICONV_LIBRARY iconv)
else()
- target_link_libraries(citra-qt core common video_core qhexedit ${QT_LIBRARIES} ${OPENGL_LIBRARIES} ${SDL2_LIBRARY} rt GLEW ${GLFW_LIBRARIES})
+ set(RT_LIBRARY rt)
endif()
+target_link_libraries(citra-qt core common video_core qhexedit ${ICONV_LIBRARY} ${COREFOUNDATION_LIBRARY} ${QT_LIBRARIES} ${OPENGL_LIBRARIES} ${RT_LIBRARY} ${GLEW_LIBRARY} ${GLFW_LIBRARIES})
+
#install(TARGETS citra-qt RUNTIME DESTINATION ${bindir})