aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/citra_qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Sacha <xsacha@gmail.com>2014-08-19 21:34:00 +1000
committerGravatar Sacha <xsacha@gmail.com>2014-08-19 21:34:00 +1000
commit90f23020f53c94dab800f7348877aae483974512 (patch)
treedffeef80b636b9f8baee1f70820dc9536f7d8567 /src/citra_qt/CMakeLists.txt
parente9c5c563a500ac19ecb2f580ce065a9010dedac9 (diff)
Add Qt5 option. Use Qt5 by default.
Diffstat (limited to 'src/citra_qt/CMakeLists.txt')
-rw-r--r--src/citra_qt/CMakeLists.txt32
1 files changed, 19 insertions, 13 deletions
diff --git a/src/citra_qt/CMakeLists.txt b/src/citra_qt/CMakeLists.txt
index 5ce4e3f1..ff1fbc46 100644
--- a/src/citra_qt/CMakeLists.txt
+++ b/src/citra_qt/CMakeLists.txt
@@ -14,7 +14,7 @@ set(SRCS
config/controller_config.cpp
config/controller_config_util.cpp)
-set (HEADERS
+set(HEADERS
bootmanager.hxx
debugger/callstack.hxx
debugger/disassembler.hxx
@@ -26,24 +26,30 @@ set (HEADERS
config/controller_config.hxx
config/controller_config_util.hxx)
-qt4_wrap_ui(UI_HDRS
- debugger/callstack.ui
- debugger/disassembler.ui
- debugger/registers.ui
- hotkeys.ui
- main.ui
- config/controller_config.ui)
+set(UIS
+ debugger/callstack.ui
+ debugger/disassembler.ui
+ debugger/registers.ui
+ hotkeys.ui
+ main.ui
+ config/controller_config.ui)
-# add uic results to include directories
-include_directories(${CMAKE_CURRENT_BINARY_DIR})
+if(USE_QT5)
+ qt5_wrap_ui(UI_HDRS ${UIS})
+else()
+ qt4_wrap_ui(UI_HDRS ${UIS})
+endif()
-add_executable(citra-qt ${SRCS} ${UI_HDRS})
-if (APPLE)
+add_executable(citra-qt ${SRCS} ${HEADERS} ${UI_HDRS})
+if(APPLE)
set(ICONV_LIBRARY iconv)
else()
set(RT_LIBRARY rt)
endif()
-target_link_libraries(citra-qt core common video_core qhexedit ${ICONV_LIBRARY} ${COREFOUNDATION_LIBRARY} ${QT_LIBRARIES} ${OPENGL_LIBRARIES} ${RT_LIBRARY} ${GLEW_LIBRARY} ${GLFW_LIBRARIES})
+target_link_libraries(citra-qt core common video_core qhexedit ${ICONV_LIBRARY} ${COREFOUNDATION_LIBRARY} ${QT_LIBRARIES} ${OPENGL_LIBRARIES} ${RT_LIBRARY} ${GLEW_LIBRARY})
+if(USE_QT5)
+ target_link_libraries(citra-qt Qt5::Gui Qt5::Widgets Qt5::OpenGL)
+endif()
#install(TARGETS citra-qt RUNTIME DESTINATION ${bindir})