aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/citra_qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Johannes Ekberg <uppfinnarn@gmail.com>2014-12-24 10:34:25 +0100
committerGravatar Johannes Ekberg <uppfinnarn@gmail.com>2015-01-09 15:50:46 +0100
commit7d7ab70279df554959eec29ff43a2eb304a3d578 (patch)
tree13443156725388ffc3fe8b1208a7a39c6d29ea93 /src/citra_qt/CMakeLists.txt
parentd46f6500363024ac58cc23ba706e26d531a6076a (diff)
Generic PLATFORM_LIBRARIES var
This both reduces redundancy in add_executable definitions, and makes it easier to link additional libraries. In particular, extra libraries are needed on OSX - see next commit.
Diffstat (limited to 'src/citra_qt/CMakeLists.txt')
-rw-r--r--src/citra_qt/CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/src/citra_qt/CMakeLists.txt b/src/citra_qt/CMakeLists.txt
index a0ba252b..420bede1 100644
--- a/src/citra_qt/CMakeLists.txt
+++ b/src/citra_qt/CMakeLists.txt
@@ -60,17 +60,10 @@ endif()
add_executable(citra-qt ${SRCS} ${HEADERS} ${UI_HDRS})
target_link_libraries(citra-qt core common video_core qhexedit)
target_link_libraries(citra-qt ${OPENGL_gl_LIBRARY} ${CITRA_QT_LIBS})
+target_link_libraries(citra-qt ${PLATFORM_LIBRARIES})
if (UNIX)
target_link_libraries(citra-qt -pthread)
endif()
-if (APPLE)
- target_link_libraries(citra-qt iconv ${COREFOUNDATION_LIBRARY})
-elseif (WIN32)
- target_link_libraries(citra-qt winmm wsock32 ws2_32)
-else() # Unix
- target_link_libraries(citra-qt rt)
-endif()
-
#install(TARGETS citra-qt RUNTIME DESTINATION ${bindir})