aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/citra_qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2014-08-23 22:22:05 -0300
committerGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2014-09-01 18:06:30 -0300
commit45976da975a21359cfcc9a05c575ed8b07575612 (patch)
treeac688d083cd597f12c42b5e424bb7a66cad50c45 /src/citra_qt/CMakeLists.txt
parent523385955c3c0af2dc2133546490f8ede0dd824f (diff)
CMake cleanup
Several cleanups to the buildsystem: - Do better factoring of common libs between platforms. - Add support to building on Windows. - Remove Qt4 support. - Re-sort file lists and add missing headers.
Diffstat (limited to 'src/citra_qt/CMakeLists.txt')
-rw-r--r--src/citra_qt/CMakeLists.txt39
1 files changed, 23 insertions, 16 deletions
diff --git a/src/citra_qt/CMakeLists.txt b/src/citra_qt/CMakeLists.txt
index 055a585a..426e4ef9 100644
--- a/src/citra_qt/CMakeLists.txt
+++ b/src/citra_qt/CMakeLists.txt
@@ -2,54 +2,61 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(SRCS
- bootmanager.cpp
+ config/controller_config.cpp
+ config/controller_config_util.cpp
debugger/callstack.cpp
debugger/disassembler.cpp
debugger/graphics.cpp
debugger/graphics_cmdlists.cpp
debugger/ramview.cpp
debugger/registers.cpp
+ bootmanager.cpp
hotkeys.cpp
main.cpp
- config/controller_config.cpp
- config/controller_config_util.cpp)
+ )
set(HEADERS
- bootmanager.hxx
+ config/controller_config.hxx
+ config/controller_config_util.hxx
debugger/callstack.hxx
debugger/disassembler.hxx
+ debugger/graphics.hxx
+ debugger/graphics_cmdlists.hxx
debugger/ramview.hxx
debugger/registers.hxx
+ bootmanager.hxx
hotkeys.hxx
main.hxx
version.h
- config/controller_config.hxx
- config/controller_config_util.hxx)
+ )
set(UIS
+ config/controller_config.ui
debugger/callstack.ui
debugger/disassembler.ui
debugger/registers.ui
hotkeys.ui
main.ui
- config/controller_config.ui)
+ )
+
+create_directory_groups(${SRCS} ${HEADERS} ${UIS})
-if(USE_QT5)
+if (Qt5_FOUND)
qt5_wrap_ui(UI_HDRS ${UIS})
else()
qt4_wrap_ui(UI_HDRS ${UIS})
endif()
add_executable(citra-qt ${SRCS} ${HEADERS} ${UI_HDRS})
-if(APPLE)
- set(ICONV_LIBRARY iconv)
-else()
- set(RT_LIBRARY rt)
-endif()
+target_link_libraries(citra-qt core common video_core qhexedit)
+target_link_libraries(citra-qt ${OPENGL_gl_LIBRARY} ${CITRA_QT_LIBS})
-target_link_libraries(citra-qt core common video_core qhexedit ${ICONV_LIBRARY} ${COREFOUNDATION_LIBRARY} ${QT_LIBRARIES} ${OPENGL_LIBRARIES} ${RT_LIBRARY} ${PNG_LIBRARIES})
-if(USE_QT5)
- target_link_libraries(citra-qt Qt5::Gui Qt5::Widgets Qt5::OpenGL)
+if (APPLE)
+ target_link_libraries(citra-qt iconv ${COREFOUNDATION_LIBRARY})
+elseif (WIN32)
+ target_link_libraries(citra-qt winmm)
+else() # Unix
+ target_link_libraries(citra-qt rt)
endif()
#install(TARGETS citra-qt RUNTIME DESTINATION ${bindir})