aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/citra/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2014-08-23 21:00:08 -0300
committerGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2014-09-01 17:41:56 -0300
commit478289140daae28cf7eabf54af3addf476aaad9c (patch)
treede13d92f26abaaf5eb0348ae35b2d1c23be497c7 /src/citra/CMakeLists.txt
parent76372feb1959c0f53d02c2278ef4a14b794a808d (diff)
Replace GLEW with a glLoadGen loader.
This should fix the GL loading errors that occur in some drivers due to the use of deprecated functions by GLEW. Side benefits are more accurate auto-completion (deprecated function and symbols don't exist) and faster pointer loading (less entrypoints to load). In addition it removes an external library depency, simplifying the build system a bit and eliminating one set of binary libraries for Windows.
Diffstat (limited to 'src/citra/CMakeLists.txt')
-rw-r--r--src/citra/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/citra/CMakeLists.txt b/src/citra/CMakeLists.txt
index 1cbe22cc..bd6c4a1a 100644
--- a/src/citra/CMakeLists.txt
+++ b/src/citra/CMakeLists.txt
@@ -10,9 +10,9 @@ endif()
add_executable(citra ${SRCS} ${HEADERS})
if (APPLE)
- target_link_libraries(citra core common video_core iconv pthread ${COREFOUNDATION_LIBRARY} ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLFW_LIBRARIES})
+ target_link_libraries(citra core common video_core iconv pthread ${COREFOUNDATION_LIBRARY} ${OPENGL_LIBRARIES} ${GLFW_LIBRARIES})
else()
- target_link_libraries(citra core common video_core GLEW pthread X11 Xxf86vm Xi Xcursor ${OPENGL_LIBRARIES} ${GLFW_LIBRARIES} rt ${X11_Xrandr_LIB} ${X11_xv86vmode_LIB} ${PNG_LIBRARIES})
+ target_link_libraries(citra core common video_core pthread X11 Xxf86vm Xi Xcursor ${OPENGL_LIBRARIES} ${GLFW_LIBRARIES} rt ${X11_Xrandr_LIB} ${X11_xv86vmode_LIB} ${PNG_LIBRARIES})
endif()
#install(TARGETS citra RUNTIME DESTINATION ${bindir})