aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/akiru/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar ShizZy <shizzy@6bit.net>2013-08-29 23:35:09 -0400
committerGravatar ShizZy <shizzy@6bit.net>2013-08-29 23:35:09 -0400
commit27474060e1287a67c45cd790d29b9095b35b2bdf (patch)
treefcbc56f1182617c01597f13e1a18dbec147d4216 /src/akiru/CMakeLists.txt
parent8404376c6ba46433a3fe0ab81e029e39f85c6b65 (diff)
adding initial project layout
Diffstat (limited to 'src/akiru/CMakeLists.txt')
-rw-r--r--src/akiru/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/akiru/CMakeLists.txt b/src/akiru/CMakeLists.txt
new file mode 100644
index 00000000..9517b11a
--- /dev/null
+++ b/src/akiru/CMakeLists.txt
@@ -0,0 +1,12 @@
+set(SRCS src/akiru.cpp
+ src/emuwindow/emuwindow_glfw.cpp)
+
+# NOTE: This is a workaround for CMake bug 0006976 (missing X11_xf86vmode_LIB variable)
+if (NOT X11_xf86vmode_LIB)
+ set(X11_xv86vmode_LIB Xxf86vm)
+endif()
+
+add_executable(akiru ${SRCS})
+target_link_libraries(akiru core common ${OPENGL_LIBRARIES} ${GLFW_LIBRARIES} GLEW rt ${X11_Xrandr_LIB} ${X11_xv86vmode_LIB})
+
+#install(TARGETS akiru RUNTIME DESTINATION ${bindir})