aboutsummaryrefslogtreecommitdiffhomepage
path: root/externals/getopt/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tony Wasserka <neobrainx@gmail.com>2015-07-14 00:53:34 +0200
committerGravatar Tony Wasserka <neobrainx@gmail.com>2015-07-14 00:53:34 +0200
commitecdfd0643a02ab9855f5674fee7475a7c15a0085 (patch)
tree51c4cf8dafb98f53b78a821ffd2522f4ee942eda /externals/getopt/CMakeLists.txt
parent1fc0347d27e05d989689ea6d06add33b1195065e (diff)
parent516169945285aee0591111576a28a0dea86faab9 (diff)
Merge pull request #927 from yuriks/getopt-fix
getopt: Fix compilation settings.
Diffstat (limited to 'externals/getopt/CMakeLists.txt')
-rw-r--r--externals/getopt/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/externals/getopt/CMakeLists.txt b/externals/getopt/CMakeLists.txt
index b4709a50..c8b745d5 100644
--- a/externals/getopt/CMakeLists.txt
+++ b/externals/getopt/CMakeLists.txt
@@ -7,5 +7,5 @@ set(HEADERS
create_directory_groups(${SRCS} ${HEADERS})
add_library(getopt ${SRCS} ${HEADERS})
-target_compile_definitions(getopt INTERFACE STATIC_GETOPT)
-target_include_directories(getopt INTERFACE ${CMAKE_CURRENT_SOURCE_DIR}) \ No newline at end of file
+target_compile_definitions(getopt PUBLIC STATIC_GETOPT)
+target_include_directories(getopt INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})