aboutsummaryrefslogtreecommitdiffhomepage
path: root/externals/getopt/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Greg Wicks <gpwicks@email.wm.edu>2015-06-22 20:59:00 -0400
committerGravatar Greg Wicks <gpwicks@email.wm.edu>2015-07-12 15:49:23 -0400
commit9930ef72ddaf8930a9bf3e574b7de69f73ecbf87 (patch)
tree30af5b4937f81d1ea7bb9148ec27e71d5501d345 /externals/getopt/CMakeLists.txt
parentf4e1d8ea36fc3f8309234b8a4a8c9f659b171c80 (diff)
Implement new argument parsing using getopt and add the corresponding library to externals
Diffstat (limited to 'externals/getopt/CMakeLists.txt')
-rw-r--r--externals/getopt/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/externals/getopt/CMakeLists.txt b/externals/getopt/CMakeLists.txt
new file mode 100644
index 00000000..b4709a50
--- /dev/null
+++ b/externals/getopt/CMakeLists.txt
@@ -0,0 +1,11 @@
+set(SRCS
+ getopt.c
+ )
+set(HEADERS
+ getopt.h
+ )
+
+create_directory_groups(${SRCS} ${HEADERS})
+add_library(getopt ${SRCS} ${HEADERS})
+target_compile_definitions(getopt INTERFACE STATIC_GETOPT)
+target_include_directories(getopt INTERFACE ${CMAKE_CURRENT_SOURCE_DIR}) \ No newline at end of file