aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar archshift <admin@archshift.com>2014-09-12 17:06:13 -0700
committerGravatar archshift <admin@archshift.com>2014-10-07 15:09:37 -0700
commite6594f9f53df456db42ab2091a7b1397070ff9c8 (patch)
treea1ca13000e379f753a155580560c20e015c2e552 /CMakeLists.txt
parentee7cfc71bd8663b77a43c5ba577074972d9b7ad9 (diff)
Added configuration file system.
Uses QSettings on citra-qt, and inih on citra-cli.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83b0863f..bbe9f76c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,7 +68,7 @@ if (ENABLE_GLFW)
if (NOT APPLE)
find_package(X11 REQUIRED)
endif()
-
+
find_package(PkgConfig REQUIRED)
pkg_search_module(GLFW REQUIRED glfw3)
endif()
@@ -127,6 +127,10 @@ get_git_head_revision(GIT_REF_SPEC GIT_REV)
git_describe(GIT_DESC --always --long --dirty)
git_branch_name(GIT_BRANCH)
+set(INI_PREFIX "${CMAKE_CURRENT_SOURCE_DIR}/externals/inih")
+include_directories(${INI_PREFIX})
+add_subdirectory(${INI_PREFIX})
+
# process subdirectories
if(ENABLE_QT)
include_directories(externals/qhexedit)