aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar bunnei <bunneidev@gmail.com>2015-01-09 14:23:24 -0500
committerGravatar bunnei <bunneidev@gmail.com>2015-01-09 14:23:24 -0500
commitd0ed01bc7f679d650322d4c299921c8a2a9f01f2 (patch)
treeea342ebd006cc2e2a3127b71ff4f8872bd13fb5d /CMakeLists.txt
parent6ae12424df58f0ea171fc75ca4b700ab1fffc192 (diff)
parentf689e9738087eaaa717a9c5dd468b05b5eaa8ce3 (diff)
Merge pull request #454 from chinhodado/patch-1
Cleanup: Remove redundant /Oi flag
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2cba5e8a..76dc2ab1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,12 +20,11 @@ else()
# /MP - Multi-threaded compilation
# /MD - Multi-threaded runtime
# /Ox - Full optimization
- # /Oi - Use intrinsic functions
# /Oy- - Don't omit frame pointer
# /GR- - Disable RTTI
# /GS- - No stack buffer overflow checks
# /EHsc - C++-only exception handling semantics
- set(optimization_flags "/MP /MD /Ox /Oi /Oy- /DNDEBUG /GR- /GS- /EHsc")
+ set(optimization_flags "/MP /MD /Ox /Oy- /DNDEBUG /GR- /GS- /EHsc")
# /Zi - Output debugging information
# /Zo - enahnced debug info for optimized builds
set(CMAKE_C_FLAGS_RELEASE "${optimization_flags} /Zi" CACHE STRING "" FORCE)