aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Lectem <lectem@gmail.com>2015-05-31 13:24:23 +0200
committerGravatar Lectem <lectem@gmail.com>2015-06-09 19:59:39 +0200
commit85183a702ab342de03d7a8d7b73e1fb0f7e346f2 (patch)
tree4fcf5606b0a3d564ef62e28ec13aee70b5fdb5f1 /CMakeLists.txt
parent513f6a277e0261b1a4d336daeac1133db46213ab (diff)
force no-tab/trailing spaces with git hook
Remove unneeded stuff from pre-commit script The check against an empty commit was not needed (it is only a security for the 1st commit after git init). It could also possibly pose problems because of the redirection to /dev/null on some windows systems. newline at EOF & fixed indent
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc742317..d958dfc3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,13 @@ cmake_minimum_required(VERSION 2.8.11)
project(citra)
+if(NOT EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/.git/hooks/pre-commit)
+ message(STATUS "Copying pre-commit hook")
+ file(COPY hooks/pre-commit
+ DESTINATION ${CMAKE_CURRENT_SOURCE_DIR}/.git/hooks
+ FILE_PERMISSIONS WORLD_EXECUTE )
+endif()
+
if (NOT MSVC)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wno-attributes -pthread")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")